Balena Fin CM3 config.txt does not change with fleet configurations

I changed the fleet configuration variables according to the documentation , by adding new environment variables like RESIN_HOST_CONFIG_init_uart_clock 64000000, and the log displayed on the balena cloud UI indicates successful editing of the config.txt. However, after rebooting, I used balena ssh to ssh into the host OS and I find that the /resin-boot/config.txt has not been changed.
Also, it seems that the configurations I added have not been registered. Please assist. Thank you.

Supervisor Version: 9.15.0
Host OS version: balenaOS 2.36.0+rev2 (development)

Hey @tenvinc

I’ve just tried this with my own fin, and it worked fine. I’m really not sure why you would be experiencing this.

Can you send the dashboard link and enable support access please?

After playing around with it, I realised that although the config file in /resin-boot/config.txt remained unchanged, when I connected my PC to the balena fin and used EMMC as usb mass storage, the config.txt file had the changes required.
Below is the link to the dashboard.

Hey @tenvinc sorry I didn’t notice the path you mentioned - /resin-boot/config.txt is the default (or the file carried over from a host OS update), /mnt/boot/config.txt is the active file, and these settings will be applied both by the supervisor and to your device. Hope this helps!

@CameronDiver I see.
No wonder I didn’t see the changes reflected :grinning:
Thanks so much for the support :grinning: