balena deploy [Error] Deploy failed net/http: TLS handshake timeout

I’m running on a VM Ubuntu 20.04.2 LTS and I’m consistently getting the following

 $ balena deploy jays_dev_testbed --build --emulated

[Build]   device_control Successfully built f5b3bbc625b2
[Build]   device_control Successfully tagged device_control_com_system_device_control:latest
[Build]   device_control Waiting...
[Build]   Built 1 service in 0:01
[Info]    Creating release...
[Info]    Pushing images to registry...
Retrying "" after 2.00s (1 of 3) due to: Error: net/http: TLS handshake timeout
Retrying "" after 2.80s (2 of 3) due to: Error: dial tcp: lookup Temporary failure in name resolution
[Info]    Saving release...
[Error]   Deploy failed
net/http: TLS handshake timeout

I’ve seen this error message show up in docker repository timeout problems [Docker pull: TLS handshake timeout]( )

Their workaround doesn’t seem applicable

I do have a marginal Internet

Internet speed test
49.4 Mbps download
2.65 Mbps upload
and it has been flaky

Is there anything I can increase the timeout interval?

Hi @jdada. Welcome to the Forums!
Could you please let me know what you are trying to achieve? By running the balena deploy jays_dev_testbed --build --emulated command you manage to complete the build step as well implicitly by not specifying an image to upload.

Do you already have a device to push your code at? If not here is a guide on how to use VirtualBox to simulate a device for balenaCloud.

Hope this helps. I’ll be happy to assist with further questions.

Sorry it’s been so long to respond, we solved the problem by moving this process onto a aws ec2 instance where the upload finishes in a few10s of seconds the process completes successfully there. I I just ran exactly the same command and it completed successfully this time of a have been experiencing bad upload bandwidth for several days around the time of my posting. the file is exceptionally large
$ docker images
REPOSITORY TAG IMAGE ID CREATED SIZE latest f5b3bbc625b2 3 weeks ago 3.26GB
device_control_com_system_device_control latest f5b3bbc625b2 3 weeks ago 3.26GB

I believe this contributes to the problem it takes well over 30 minutes to push the image.

Hi @jdada, no worries at all, I’m glad to hear moving to AWS EC2 got things moving fast enough for the timeout not to be a problem. We really appreciate you sharing the resolution too, so that other users who might experience the same can see what worked for you!