Balena Dash suddenly dead - whole fleet affected/down

Hi, I’ve just upgraded our units runnig on generic x86’s. Standard intel Atom mini and one Intel i5 pc’s.
Build used: Generic x86_64.

After the update I face a restart loop on FBCP, and from what I can google, the error is caused by running a ARM application on a unsupported platform. How can this be?

Tried with a “clean” Balena Dash image → Etcher → reinstall from USB → Same result.

The computer does boot, but stalls on the Balena boot logo - it’s online in Balena Cloud. (the computer is supposed to boot into a website in Chromium)

I face no issues on our Raspberry Pi4 units.

From BalenaCloud terminal window on FBCP:

Restarting service 'fbcp sha256:753c9b5556ce8574b963a6396bd74f2c8e9e0365f3b982a51f66131719e3ecc3'
 fbcp  standard_init_linux.go:211: exec user process caused "exec format error"
Service exited 'fbcp sha256:753c9b5556ce8574b963a6396bd74f2c8e9e0365f3b982a51f66131719e3ecc3'

I have been running Balena Cloud with Dash for quite some time, but this one I do not understand?