Balena CLI and LivePush SecretPopulationError

I was trying to use the Balena LivePush feature. I have a Windows 10 Pro but I am using the Windows Subsystem for Linux (WSL) v2 with Ubuntu 20.04. I have installed the Balena CLI v13.1.1 with the standalone Linux ZIP file as recommended in the Installation Instructions. When I run the balena push 7871a2e.local --debug command, I get the following output:

[debug] new argv=[/home/cfield/Code/balena-cli/balena,/snapshot/versioned-source/bin/balena,push,7871a2e.local] length=4
[debug] Deprecation check: 0.03249 days since last npm registry query for next major version release date.
[debug] Will not query the registry again until at least 7 days have passed.
[Debug]   Using build source directory: .
[Debug]   Pushing to local device: 7871a2e.local
[Debug]   Checking we can access device
[Debug]   Sending request to
[Debug]   Checking device supervisor version: 12.11.22
[Info]    Starting build on device
[Debug]   Loading project...
[Debug]   Resolving project...
[Debug]   docker-compose.yml file found at "."
[Debug]   Creating project...
[Debug]   Tarring all non-ignored files...
[Debug]   Tarring complete in 138 ms
[Debug]   Fetching device information...
[Debug]   Sending request to
[Debug]   Found build tasks:
[Debug]       dashboard: build [./dashboard]
[Debug]       database: build [./database]
[Debug]       backend: build [./backend]
[Debug]   Resolving services with [jetson-xavier-nx-devkit|aarch64]
[Debug]   Found project types:
[Debug]       dashboard: Standard Dockerfile
[Debug]       database: Standard Dockerfile
[Debug]       backend: Dockerfile.template
[Debug]   Probing remote daemon for cache images
[Debug]   Using 136 on-device images for cache...
[Debug]   Starting builds...
(HTTP code 500) server error - invalid character '/' looking for beginning of value

SecretPopulationError: (HTTP code 500) server error - invalid character '/' looking for beginning of value
    at populateSecrets (/snapshot/versioned-source/node_modules/resin-multibuild/build/build-secrets/index.js:87:15)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)

For further help or support, visit:

I believe I have successfully used Balena LivePush from this computer and within WSL2 before, but it has been a while and the last time I used this particular host machine was probably before I setup Balena Secrets for the build. I also tried from the Windows 10 Pro environment using the Windows Balena CLI (v13.1.1) and PowerShell. I get the same error and output from the same command.

I just tried from my Linux Ubuntu 20.04 workstation, which I normally use with the Balena LivePush development feature, and the build occurred without this error. This had Balena CLI v13.1.0 installed. I then just upgraded to Balena CLI v13.1.1 and received the above error when using the Balena LivePush feature from my Linux Ubuntu 20.04 computer.

Next, I downgraded all copies of the Balena CLI from v13.1.1 to v13.1.0 and retried the Balena LivePush command from each environment (Windows 10 Pro, Ubuntu 20.04 WSL2, Native Ubuntu 20.04), and the builds successfully completed.

There appears to be a regression error in the latest release of the Balena CLI (v13.1.1). When I started to submit an issue to the Balena CLI tracker, the template suggested I post in the Balena forum first.

Just in case someone else comes across this issue and/or a similar problem, I created an issue in the Balena CLI issue tracker, and it has been resolved as of v13.1.8.

@ts-cfield, thank you for reporting the issue and for updating this thread when it was fixed. :+1: