Arducam UC-572 (IMX298) not working

i’ve been trying to connect a UC-572 Arducam camera to a balenafin 1.1.1 through the CSI cam0 connector without success, even after having installed the drivers

Using a raspberry pi camera v2.1 instead, by running
i2cdetect -y 0
it successfully gets recognized at address x64, and running
vcgencmd get_camera
supported=1 detected=1.

Neither of the two are successful when using the arducam

Looking at the balenafin schematics i’ve noticed the pins
gpio44 → CAM1_IO0
gpio45 → CAM1_IO1
from the arducam website pin18 of the camera corresponds to 3.3V rail.
Now what i think the problem is, is that with the included 22pin->15 pin connector the 3.3V rail goes to the CAM1_IO1 (gpio45) of the CSI connector on the balenafin board, could this be the issue?

From the arducam pin specifications i powered pin 17 POWER_EN (using the raspi-gpio command), by powering on gpio44, doing so still doesn’t seem to fix the issue.

Hello @luca1 ,

Is powering the camera from gpio45 the suggested approach by Arducam? Depending on the power requirements of the camera, the GPIO might not be able to provide enough current to power it.

Apart from that, I have a few questions that might help us understand what could be going on:

  • What OS are you running on the balenaFin? Raspbian or balenaOS?
  • Have you tried the same setup on a standard raspberryPi? That could help us rule out a camera HW issue.
  • Where did you see that the 3v3 rail goes to CAM1_IO1 on the CSI connector? I wasn’t able to find that information on Arducam’s website.
  • You first mentioned that the 3v3 rail was connected to GPIO45, but you then said you enabled GPIO44 and it didn’t make a difference. Are you sure you’re enabling the right pin? This might just have been a typo, but worth checking anyways.


Hi @luca1

Do you still need help with this? Let me know if you’ve had the chance to look at some of the questions above.

Hi, thanks. I just follow the arducam driver setup and I solved the problem.