ADS-B stuck in online (VPN only)

What can I do the get the system going again.
I have already rebooted but without effect.
I do not want to loose all the configs in the system.
All help is welcome.

Hey @Placemaster welcome to the forums.

Could you describe if there was anything that happened that led up to the point where your device is in ‘VPN only’ mode? Did you make any changes or any make any updates?

Here are some things you can try though:

  • If the device’s system time is incorrect, it may cause issues with SSL certificates and prevent connections to the balenaCloud API. Check the device’s system time using the command date and correct it if necessary.
  • Some networks may have strict firewall settings that could be blocking the device’s connection to the balenaCloud API. Verify that your network allows traffic to * on ports 80 and 443, as well as traffic to * on port 443.
  • Check the logs of the balena supervisor and the balena engine for any errors or issues that could be causing the problem. You can use the following commands to access the logs. balena supervisor logs: journalctl -u balena-supervisor --no-pager (or resin-supervisor if the device is on an older OS version. balena engine logs: journalctl -u balena --no-pager
  • Run device diagnostics from the balenaCloud dashboard. This can help identify any issues with the device’s hardware or software that could be causing the VPN-only mode issue.

We also have the device debugging masterclass which may give you some more ideas: Balena Device Debugging Masterclass - Balena Documentation

It’s worth noting though that if you’re using Ketil’s balena-adsb app (balenaHub - IoT embedded device apps, edge computing resources, and developer tools) all your configuration should be in the dashboard and not at risk if the device goes wrong :slight_smile:

Hope this helps, and please come back to us if you’re still stuck.

Hi @chrisys,

I wanted to update the system to the latest versions.The host OS version was updated but the Supervisor version didn’t. It then got stuck in this mode.

I already looked at the diagnostics and all is fine except the supervisor part.

Below is the log. It is repeating the same error.

Mar 27 13:18:58 7e60489 balena-supervisor[14051]: Error response from daemon: No such container: resin_supervisor
Mar 27 13:19:05 7e60489 balena-supervisor[14061]: balena_supervisor
Mar 27 13:19:05 7e60489 balena-supervisor[14150]: active
Mar 27 13:19:06 7e60489 balena-supervisor[14153]: Container config has not changed
Mar 27 13:19:08 7e60489 balena-supervisor[14212]: standard_init_linux.go:219: exec user process caused: exec format error
Mar 27 13:19:12 7e60489 systemd[1]: balena-supervisor.service: Main process exited, code=exited, status=1/FAILURE
Mar 27 13:19:12 7e60489 systemd[1]: balena-supervisor.service: Failed with result 'exit-code'.

Before the system ran for 2 years without a problem.

I will look into the debugging masterclass.

@Placemaster ok so the host OS updated successfully - what version are you on now? If you remember, what version were you on before the update?


See the details below.

I do not remember on what host OS version I was. Supervisor version has not changed.

The release is also waiting on an update.

OK great - have you tried updating the supervisor version manually using the option on device settings? 14.9.4 is the version that comes with balenaOS version 2.113.18.

Yes Tried that.
But if I select a version I can not get it to execute. There is not button to click on.

In the actions tab (under devices) supervisor update is not showing up.

I changer browser (from Safari to Chrome) and now it looks like I can do a manual upgrade).
I’ll keep you posted.

Yes manual updating did the trick.
As said it was not working with Safari but with Chrome it did.

To update manually go to devices → select your device and go to settings.
Scroll down and select the release you want and you can also select OS version and Supervisor function.
It then will update the system.

Great @Placemaster thanks for coming back here! Glad to hear you got it going :+1: