Windows resin-cli SSH

I’m unable to get ssh to work with the resin-cli on Windows 10. Is there another npm package to install? I tried the ssh npm package, but it failed to install. Cygwin maybe? Any help would be great.

resin ssh
? Select a device device-name (75a1806)
Connecting with: 45a3906c9e0fd2fc52e18f9b2db2f507abe21fed08c8d9bac772e335a606b6
’ssh’ is not recognized as an internal or external command,
operable program or batch file.

yeah, that’s insufficient documentation, we have an open issue for that on Github, let’s see whether @kostas has some comments in the meantime?

Got some feedback in this comment on the issue, and tested it out :wrench: . For resin ssh you could use Git for Windows. Install it and run Git Shell (from the Start / Cortana Menu). Add your keys to the ~/.ssh/ directory, and let ssh know about them, if you haven’t.

For example use ssh-agent:

ssh-add.exe ~/.ssh/<private key file>

or alternatively set up a ~/.ssh/config file with something like

Host *
 IdentityFile ~/.ssh/<private key file>

where you replace <private key file> with the appropriate filename.

After this resin ssh should work. Will be doing some more testing (this above worked for me, but haven’t tried for too long), and we’ll update the Windows instructions for resin-cli. :pen_fountain:

1 Like