WiFi issues with Balena Dash


I’m looking to get a bit of help with the Balena Dash project (GitHub - balenalabs/balena-dash: Build a Raspberry Pi based desktop dashboard for stats, photos, videos and more!).

We are using this with Raspberry Pi 4’s, but sometimes when we reboot a Raspberry Pi (either by replugging power, rebooting via Balena or even restarting the “kiosk” container), when the device/container boots up there is no internet connection.

The wifi-connect service then activates, and we can choose the WiFi again using that. However, this does not always re-connect it again.

There are times when it does connect, and it will stay connected until we reboot the device or container again. The WiFi details are not changing, and we have absolutely no firewall configured at any point in the network.

What is the best way to debug why the device is not connecting back to the internet?

I have tried logging into the device locally and running nmcli device wifi connect SSID password 'PASSWORD', this will connect the device back to the internet and it shows in balenaCloud with “Online (Heartbeat only)”

Also the system-connections/balena-wifi-01 file has the correct WiFi details.

1 Like

Can you please rule out signal strength issues first, by placing your Pi very close to the WiFi AP? We’ve observed this behaviour in instances where there is a very weak and fluctuating WiFi signal…

It’s currently within a meter of the router, without anything in-between.

It also doesn’t seem to ever re-connect once disconnected, unless I manually run the nmcli command to reconnect it.

I do believe it is the WiFi connection, as I have tried other WiFi’s and they all work fine. However, other devices have no issues connecting and remain connected. I guess the problem we have at the moment is that it doesn’t seem to bother reconnecting. Are there any logs for this?

Exact same issue here, same hardware. Also; tried with both 2.4 and 5ghz network, and mixed. Also hidden and visible SSIDs has been tried on both bands, no luck there either.
No wifi-issues in the same location for other devices, not even Intels Computesticks.

An ideal solution would be for it to reconnect once it disconnects. This does not seem to happen regardless.

Thanks for providing the details here. I can suggest two things here:

  • Share us the logs from wifi-connect a new set of eyes might help find something a miss or we can check with existing issue/pattern.
  • There is an optional step here with wifi-connect (wifi-connect/start.sh at master · balena-os/wifi-connect · GitHub) - putting this in might help resolve especially in cases where you see the network taking a bit longer than expected to connect.

I suspect the second might help you resolve the issue. Do let us know how it goes?

I think I may have seen this behavior before, I am going to run a quick test on a Pi 3 that I have that might be able to duplicate this tomorrow. I’ll report back my findings.

I have tried for a few days to replicate this issue, but, have not been successful. I will keep my eyes open for any other examples of this behavior, but at the moment I can’t duplicate it. :expressionless: