Use Microphone with NUC devices

Hello everyone.

I was running some exploration about how to access a microphone’s input from a Balena container running in a NUC device.
Initially, I tried to use the NUC’s built-in mic, but without success. I moved on to try with an external jack mic but with the same result.

I am using the browser block and I am loading this URL. It is basically a website that tests a mic.
I accessed the website and allows for the mic’s usage but no sound is captured. I check all browser settings without success.
I try other similar websites always with the same result.

Inspired by this thread I follow the instructions to make sure the browser permission and settings are OK.
The first red flag is: The list of available mic devices presents shows a lot of intel stuff but nothings about the external mic.

By SSH in the browser module and running amixer controls i get some entries but I really do not know how relevant they are.

numid=8,iface=CARD,name='Front Headphone Jack'
numid=4,iface=MIXER,name='Capture Volume'
numid=6,iface=MIXER,name='Mic Boost Volume'
numid=47,iface=MIXER,name='Digital Capture Volume'
numid=7,iface=CARD,name='Mic Phantom Jack'

I tried to change some values as suggested in the same thread but still do not able to capture audio on the mic.

So someone any digestion how can I try next?

Thanks a lot,


Following the browser block’s documentation, I am also testing using the audio block.
It works for audio output but still no success with the mic’s input.

No success until now. Any ideas will be appreciated.

Hi there,

Not sure I can help a lot, because I don’t have a NUC, but I’ll share an idea just in case…
When I tried your micTest url, it wouldn’t work on Safari, but it did on Chome. So I was thinking that maybe your browser (chromium in the case of the block) is not displaying correctly the result.
The only project I’ve tried with a (webcam) mic has been this one, and I also struggled a bit to make it work but that same thread helped me. But in the end, I could here myself on the other side of the conference, so the mic _was_working.
Give it a try and see if you reach to some conclusion. Good luck!

Thanks a lot for the idea :smiley:
I was studying that project looking for help too. I would say my scenario is a simplification of it since we both use the browser block. I followed all the settings in the tutorial and all the ones in another topic about some recent changes on it.
I don´t think the issue is the website for test the mic since I was given a try on several different websites including google meets. I tried Jitsi meeting too, whiteout success.
I will keep fighting on this.
Thanks once again.

Hi Nuno, a couple of quick thoughts. First and foremost, are you running multiple containers, or, just one container. The reason for asking, is that you may need to run the container as privileged in order to access the microphone, or, a least mount the devices via a docker-compose file if nothing else. Secondly, I was not even aware that NUC’s had built in Mic’s for that matter, ha! Mine doesn’t seem to have one, or at least I should say that there are no headphone / audio jacks on mine. The only way mine would have a Mic, is with USB Mic hooked up. Finally, just for testing purposes, you could try running a full desktop/GUI in a container, as opposed to just the browser block, simply for checking to see if the Mic is picked up and making experimentation easier. Then, start cutting back down your Dockerfile once you verify the Mic works. Hope that helps!

Hello, David thanks a lot for sharing those suggestions.

I tried it first as a single container (using the browser block) and then added the audio block to the project to give it a try.
I am using the flag privileged: true in the docker-compose.yml. that’s what are you talking about right?
As a troubleshoot I tried to access a webcam from the browser container and I can access it, in my mind it excludes the permissions issue, but let me know your thoughts.

I would like to give it a try with a USB mic but for now, I have not one available.
Thanks for the idea of using a full desktop container I will give it a try.

I have finally some breakthrough :smiley:
I followed David’s suggestion and tried it in a desktop/GUI container Without success.

Then I ask a colleague of mine to test with a USB mic and it worked. So it really looks like there is a problem with using jack connector.
I am able to get sound from NuC’s jack, but I am not able to use the mic.

Hi Nuno, is the mic jack on your NUC a combo-jack or a dedicated one?

Hello Genadi,
Same jack connector for both: audio and mic. This is what you mean by a combo jack?

Also: I tried with both: dedicated microphone and the usual auricular+mic.

I missed your reply here Nuno, I apologize! When using a full desktop container, plus a USB Mic, it works…but not with the Mic/Headphone jack? What exact model number is your NUC? I am curious if we are 100% certain that jack is actually a combo input/output jack, or is just a speaker output. Of course, flashing the NUC back to Windows to test if it works there is a long process, but, could be worth a test to see if the jack is functioning properly with both Mic/Speaker there.

Hello David, thanks for the follow-up.

Yes, that’s it!

My test setup is using the model NUC7i7BNH. I tried also with NUC7i7DNKE.
I actually did the test using Windows and I can say I am sure the mic works in the jack connector.

Hey Nuno,

Can you confirm that the microphone works on another linux distribution like Ubuntu or Debian? If so, can you tell us what modules it is using, and what ALSA configuration files?


I was tried to run Debina inside a container and it didn’t work this way.
But I never tried it without balena (just Debian / Ubunto).
I can give it a try and back to you with the results.

Hey, did you have any luck with the microphone running stock Ubuntu or Debian?

Hello Kyle,

yes, I had the chance to perform the test. Sorry for the delay.

Using a stock Ubuntu I was not able to use the jack’s mic. However, I was able to use the NUC’s built-in microphone.

Hi. could you please confirm the model of NUC device you are using?

Hello, I think I already mention it above. My NUC’s model is the NUC7i7BNH.

Hi, Nuno. I tried BalenaOS with the site you mentioned, and the mic’s didn’t work, but when I tried the link in the Balena video project, it worked.

Could try changing the website to maybe Google Meet or Jitsi Meet and see of either of those work for you?

I was tried both: Google Meet and Jitsi Meet as well as with other mic test websites never manages to use jack’s microphone. USB microphone works well.