Use Microphone with NUC devices

Hello everyone.

I was running some exploration about how to access a microphone’s input from a Balena container running in a NUC device.
Initially, I tried to use the NUC’s built-in mic, but without success. I moved on to try with an external jack mic but with the same result.

I am using the browser block and I am loading this URL. It is basically a website that tests a mic.
I accessed the website and allows for the mic’s usage but no sound is captured. I check all browser settings without success.
I try other similar websites always with the same result.

Inspired by this thread I follow the instructions to make sure the browser permission and settings are OK.
The first red flag is: The list of available mic devices presents shows a lot of intel stuff but nothings about the external mic.

By SSH in the browser module and running amixer controls i get some entries but I really do not know how relevant they are.

numid=8,iface=CARD,name='Front Headphone Jack'
numid=4,iface=MIXER,name='Capture Volume'
numid=6,iface=MIXER,name='Mic Boost Volume'
numid=47,iface=MIXER,name='Digital Capture Volume'
numid=7,iface=CARD,name='Mic Phantom Jack'

I tried to change some values as suggested in the same thread but still do not able to capture audio on the mic.

So someone any digestion how can I try next?

Thanks a lot,

Nuno

Following the browser block’s documentation, I am also testing using the audio block.
It works for audio output but still no success with the mic’s input.

No success until now. Any ideas will be appreciated.
Thanks.

Hi there,

Not sure I can help a lot, because I don’t have a NUC, but I’ll share an idea just in case…
When I tried your micTest url, it wouldn’t work on Safari, but it did on Chome. So I was thinking that maybe your browser (chromium in the case of the block) is not displaying correctly the result.
The only project I’ve tried with a (webcam) mic has been this one, and I also struggled a bit to make it work but that same thread helped me. But in the end, I could here myself on the other side of the conference, so the mic _was_working.
Give it a try and see if you reach to some conclusion. Good luck!

Thanks a lot for the idea :smiley:
I was studying that project looking for help too. I would say my scenario is a simplification of it since we both use the browser block. I followed all the settings in the tutorial and all the ones in another topic about some recent changes on it.
I don´t think the issue is the website for test the mic since I was given a try on several different websites including google meets. I tried Jitsi meeting too, whiteout success.
I will keep fighting on this.
Thanks once again.

Hi Nuno, a couple of quick thoughts. First and foremost, are you running multiple containers, or, just one container. The reason for asking, is that you may need to run the container as privileged in order to access the microphone, or, a least mount the devices via a docker-compose file if nothing else. Secondly, I was not even aware that NUC’s had built in Mic’s for that matter, ha! Mine doesn’t seem to have one, or at least I should say that there are no headphone / audio jacks on mine. The only way mine would have a Mic, is with USB Mic hooked up. Finally, just for testing purposes, you could try running a full desktop/GUI in a container, as opposed to just the browser block, simply for checking to see if the Mic is picked up and making experimentation easier. Then, start cutting back down your Dockerfile once you verify the Mic works. Hope that helps!

Hello, David thanks a lot for sharing those suggestions.

I tried it first as a single container (using the browser block) and then added the audio block to the project to give it a try.
I am using the flag privileged: true in the docker-compose.yml. that’s what are you talking about right?
As a troubleshoot I tried to access a webcam from the browser container and I can access it, in my mind it excludes the permissions issue, but let me know your thoughts.

I would like to give it a try with a USB mic but for now, I have not one available.
Thanks for the idea of using a full desktop container I will give it a try.

I have finally some breakthrough :smiley:
I followed David’s suggestion and tried it in a desktop/GUI container Without success.

Then I ask a colleague of mine to test with a USB mic and it worked. So it really looks like there is a problem with using jack connector.
I am able to get sound from NuC’s jack, but I am not able to use the mic.

Hi Nuno, is the mic jack on your NUC a combo-jack or a dedicated one?

Hello Genadi,
Same jack connector for both: audio and mic. This is what you mean by a combo jack?

Also: I tried with both: dedicated microphone and the usual auricular+mic.