USB stick - invalid size, unable to format

Hi there

I have a 2GB usb stick which I used to create a bootable Elementary OS (Loki), using Etcher (for Mac) as instructed.

After installing Loki on a HP Pavilion DV7, I encountered suspend issue, Loki can’t get up from sleep on this one, so I wanted to try with Ubuntu.

I used the same USB stick and Etcher, to create bootable Ubuntu 16. Etcher created it but was unable to verify it, and I got an error.

Since then, I ended up with a broken USB stick which appears to have 8MB now instead of 2GB. I cannot format it, I cannot make it work.

I tried “diskutil” on a Mac, but cannot erase it, cannot creaty any partitions due to lack of space as it only shows 8MB.

I tried “diskpart” on a PC, tried to “clean” it, no luck, still 8MB, raw space, nothing else.

I tried “gparted” on Linux, and all I see is unlocated 8MB.

I’ve have years of experience with computers, but never had such problem, and I’ve no idea what to do it this point. Does anyone have an idea how to fix this? I’d really appreciate some help. Thanks

Hey there,

Etcher displays a validation error if it can’t ensure that every single byte was written correctly (it does so by using a CRC32 checksum).

Regarding the “broken” drive, Ubuntu ISOs are a bit peculiar, since they make non-standard modifications to partition tables to make the drives boot in some strange types of computers (see, and thus confuses certain operating systems.

Notice that the size that your operating system will display is the size of what’s defined in the partition table, which might be (and will be the case for Ubuntu ISOs) ignoring a part of the drive.

What you need to do is recreate the partition table, and then you can create partitions that make use of your complete drive.

On macOS, I believe you can wipe out the partition table by running diskutil eraseDisk free UNTITLED /dev/diskN on the terminal, where diskN corresponds to your drive (be sure to double check you don’t remove the partition table from another important drive!)

Unfortunately this doesn’t work, still only 8MB instead of 2GB. Here is some additional info from Mac, Linux and Windows, maybe this will be helpful:

Output from "lsblk" on Linux:

sdb      8:16   1    8M  0 disk 
sr0     11:0    1 1024M  0 rom
sda      8:0    0   64G  0 disk 
├─sda5   8:5    0  510M  0 part [SWAP]
└─sda1   8:1    0 63.5G  0 part /
sr1     11:1    1 1024M  0 rom

Output from "diskpart list" disk on Windows:

Disk ###  Status         Size     Free     Dyn  Gpt
  Disk 0    Online           64 GB      0 B
  Disk 1    Online            8 MB      0 B

Output from "diskutil list" on a Mac:

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                                                   *8.4 MB     disk3

Can you try the instructions here:

Also, can you show us the output of the commands that clean the drive, so we can assist you in making sure they ran properly?

Sure, here is the output:


Microsoft DiskPart version 6.1.7601
Copyright (C) 1999-2008 Microsoft Corporation.
On computer: XXXXXX

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online           64 GB      0 B         
  Disk 1    Online            8 MB  8128 KB         

Disk 1 is now the selected disk.

DiskPart succeeded in cleaning the disk.

Mac OS:

diskutil eraseDisk free UNTITLED /dev/disk3
Started erase on disk3
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Finished erase on disk3

Linux (Elementary OS):

sudo dd if=/dev/zero of=/dev/sdb bs=512 count=1 conv=notrunc
1+0 records in
1+0 records out
512 bytes copied, 0.025282 s, 20.3 kB/s

Unfortunately, nothing happens after all that, when I use "sudo fdisk -l" this USB stick is still listed as 8MB:

Disk /dev/sdb: 8 MiB, 8388608 bytes, 16384 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Can you send us a dump of those 8 MBs for us to analyze?

Sure, what would be the best way to do it? I’m on a Mac, but can use LInux or Windows if necessary.

EDIT: Ok. I created a disk image using DIsk Utility, and also another one using “dd” command.
Now, should I post it here?

Awesome, thanks a lot man. You can send them to

Done! I’ve sent you the files just now. Let’s see what’s there :slight_smile: Thanks!

Hey @waveman – I’ve just had a look at the images you sent us, and it looks like the ChipsBank controller firmware got corrupted somehow, and is spewing out parts of its firmware when being read:

00000000  00 80 02 02 1f 00 00 00 43 68 69 70 73 42 6e 6b  | ........ChipsBnk |
00000010  46 6c 61 73 68 20 44 69 73 6b 20 20 20 20 20 20  | Flash Disk       |
00000020  35 2e 30 30 99 29 2f 4b 8a 08 4c 3a 8d 07 3d 50  | 5.00.)/K..L:..=P |
00000030  fa 73 56 05 43 30 81 36 56 4f eb 78 2f 20 5a 04  | .sV.C0.6VO.x/ Z. |
00000040  d3 52 ff 30 4b 6a fb 2c 5e 0b f3 6e 0d 76 6b 56  | .R.0Kj.,^..n.vkV |
00000050  2f 28 b9 2f 96 59 cf 40 a0 46 38 6d 2c 24 ec 32  | /(./.Y.@.F8m,$.2 |
00000060  40 30 f2 0e ea 2c e8 0f 23 3f e4 4d b6 39 50 7a  | @0...,..#?.M.9Pz |

This appears to be a pretty common problem with USB storage devices with chips from ChipsBank, judging by the amount of search results it generates.

There appeared to be a tool to repair those chipsets, called “umptool”, but all currently available sources of it seem a bit shady, while the original source has become unavailable, so I can’t really recommend it. There’s also no tooling available from the manufacturer;

Not sure what a good way forward would be, or whether that drive is still salvageable, unfortunately.

Hej @jhermsmeier - thank you very much for the effort, I’ll try to play with the software you mentioned, I have nothing to loose but might be able to fix it somehow. Since different “umptool” versions are designed for a specific ChipsBank controllers, do you think you can find out somehow the name of it?

Also, since we don’t know how exactly it got corrupted, I’ll tell you when exactly this happened.

The procedure was like this:

  1. I formatted this stick on a Mac, created FAT32 partition on GUID partition map.
  2. I used Etcher to put Elementary OS on it
  3. I didn’t reformat it afterwards
  4. I used Etcher again to put Ubuntu on it (without reformatting it as I already mentioned)
  5. Etcher completed it, but stopped during verification process due to en error (I forgot to make a note of it)
  6. Since then, this USB stick shows only 8MB and it’s unusable.

Maybe this will help to find out it if there was something related to Etcher activity.