USB Size Becomes 733 Kb

I’m using Balena Etcher to put parrot os on a 256 GB flash drive. It successfully mounts the operating system, but in doing so changes the disk size to 733 Kb. I can restore the disk back to its original size, but no matter what I do the drive ends up with only 733 Kb once I’ve etched Parrot. I’ve tried different drives, but have gotten the same results every time. If anyone has a solution I’d appreciate it!

Hi, Own, sorry to here you’re having problems flashing your operating system to your flash drive.

It sounds like there’s definitely something going wrong here. Can you share a link to the image your trying to download? Can you also share your operating system version and the version of balenaEtcher you are using so we can try to replicate this issue?

Also, do you have another computer and/or flash drive you can test this on to see if it is having the same issue? These diagnostic steps might help us narrow down the issue.



Hi Zane,
Thanks for getting back to me so quickly. Here’s a link to the Parrot OS Website: I can’t upload the actual .iso I’m using, but you should be able to download it from the website. Parrot Security MATE ISO 64 is the version I’m trying to boot. I’m using the latest version of mac os as well as the latest version of balena etcher. I’ll try again on a computer running windows to see if anything changes.

When you’re flashing Parrot to the drive, does the drive say it’s flashed the whole thing? It should take a minute or two to flash…does it do that, or does it just immediately say it’s done? Also, does it give you any kind of error message, or does it say “Successfully flashed”?

I just flashed Parrot OS to my USB drive, and it worked fine, btw, so if there are no error messages, I would try with a different flash drive and see if that works.

It takes a while to flash and doesn’t give me any errors. I’ll take a screen recording of the process and send it to you.

Were you able to try on a windows computer? It sounds like there have been some problems with the Big Sur update, so that could potentially be the problem.

I haven’t yet tried on the windows computer, I’m going to do that next.

Heres a link to the screen recording.

Ok, I think I see what the problem is. When you flash the Parrot OS to the drive, it flashes two partitions. One is detectable by MacOS, and that one is around 700kb. I believe this is the boot partition that loads the real boot loader that boots the OS, that or it is some kind of backup boot loader that just loads grub so you can fix the OS and whatnot if it becomes corrupted.

In any case I believe the drive was flashed even though you don’t actually see the main partition in Disk Utility.

Try booting from the USB drive as is and see if that works…if not, come back and let us know.

I’m not an expert on boot loaders or anything, so I probably butchered that explanation, but you get the gist :slight_smile:

Ok… I’ll look into that. I’ve already booted into parrot os, and when i do there is only 700kb of storage available, but I’ll look into what you said.