UART on RPi4 available?

I’m trying to deploy our app to RPi4 with the new image.
Question: I’m missing the UART settings on the RPi4’s Fleet configuration tab:

(picture from the RPi3).

How can I enable UART for RPi4?
I used to have our custom hardware available on /dev/ttyS0 but this device does not exist.


just found out that manually adding the
RESIN_HOST_CONFIG_enable_uart parameter and setting value to 1 did the magic ^^

Works now :wink:


Thanks for confirming, I will make a point to find out why it isn’t exposed in the UI though :+1:

1 Like