ttyUSB device not detected after BalenaOS update

I upgraded two devices from balenaOS 2.29.0+rev1 to balenaOS 2.38.3+rev4 and now my USB serial adapter is no longer detected.
A USB device is detected but the USB tree does no longer show the ttyUSB endpoint.
Did you remove any drivers? Changes to the udev system?

When I plugin the USB device on a device with the old BalenaOS, dmesg says:

[22067.664660] usb 1-7: new full-speed USB device number 7 using xhci_hcd
[22067.791853] ch341 1-7:1.0: ch341-uart converter detected
[22067.792125] usb 1-7: ch341-uart converter now attached to ttyUSB1

But when I plugin the USB device on a device with the new BalenaOS, dmesg says:

[ 966.292273] usb 1-7: new full-speed USB device number 5 using xhci_hcd

And I can’t downgrade the BalenaOS! Ouchh!

So do I have to backup the persistent data, reinstall, and restore persistent data, transfer all Balena settings from the old to the new device and delete the old device and … ???


I’m not aware of any change that should cause this. Can you please do the following:

  • unplug your serial USB adapter,
  • boot 2.29.0+rev1,
  • once fully booted, plug the serial USB adapter,
  • share the dmesg output with us.

Also what device it is?

Yes, there’s no support for the balenaOS downgrade. It’s documented here:

Note: Once a successful host OS update has been made, it is not possible to roll back to a previous OS version.

Yes, you can do it in this way. Backup persistent data, reinstall the old OS and transfer device specific settings to the new device.

Thanks for the dmesg output! What device it is?

The label says:


Thanks for this information. Also, can you share the device type you’re using? Not the USB dongle, but if the main device is RPi 3, Intel NUC, Odroid, … Thanks!

Sure, sorry for not having that included: Intel NUC

Don’t be sorry, that’s okay. I shared this info with developers and will come back when I’ll have more info from them.

Just FYI - asked developers and they’re pretty busy right now. We will have an answer for you, but not sure when.

Hi. This should be solved by

Thx, is there any forecast on when this will be included in a release?

Hi again,

Our OS release cycles are usually approximately every couple of weeks, so whilst I can’t guarantee it, I’d expect this to be within a fortnight.

Best regards, Heds

Update: I have a confession to make…

It seems that the issue with this kernel module cannot be blamed on the Balena folks.
It turns out that our system worked with balenaOS 2.29.0+rev1 only because we ourselves had compiled the kernel module for our USB device.
So when we updated to balenaOS 2.38.3+rev4, the compiled module did no longer match the kernel.

And I wrongly assumed the balenaOS 2.38.3+rev4 had a regression that broke our system. Sorry about that, and thanks for the support.

Hi. We are glad that you found the issue. That is the most important thing. We are here for any other questions. In the meanwhile, enjoy our platform.