Stuck at the CLI install step

raspberrypi3
balenadash

#1

Help!

I’m trying to set up a balenaDash web frame with a Raspberry Pi and have hit a snag trying to install CLI. Up to this point, the instructions have been rather good and clear (and my device looks like the one pictured under the “Assembling the display and the case” section of https://www.balena.io/blog/make-a-web-frame-with-raspberry-pi-in-30-minutes/), but I’m now stuck.

The documentation ( https://www.balena.io/docs/reference/cli/#install-the-cli) speaks of two methods for installing CLI; the first is through npm and there is a screen capture of a command line with the necessary commands. However, there are no directions on how to get to that specific command prompt ($). When I try to use the terminal from the device page, I’m put into a bash shell.

Similarly, I can’t SSH into a terminal on the device itself using the Raspberry Pi Finder; the connection is refused.

The second method is to download the CLI as a standalone binary. I followed the instructions, downloaded the ZIP file, unpacked it to a balena-cli directory on my C: drive and added the path as instructed. However, when I open a command prompt in Windows, navigate to the directory and issue a “balena” command I get an error message that says:
‘balena’ is not recognized as an internal or external command, operable program or batch file.

I’ve also tried using the “balena login” command in the bash shell, and logged in using Docker credentials, but still can’t seem to figure out how to get CLI installed.

I’m REALLY confused and don’t know what to do to get past this step. Any help would be appreciated.

Thanks,
pete


#4

Hey @pdsavas ,

Thanks for posting your question here,
As you are on windows, when you navigate to the C:\balena-cli folder (or to the place you unzipped the files to), instead of just using balena, can you try balena.exe. For example using balena.exe login and see if it works for you.

Please let me know if that works, otherwise we can keep working until we get everything up and running.

Cheers


#6

@dansku,

There is no balena.exe file in the c:\balena-cli folder. It contains three sub-directories: drivelist, ext2fx, and resin-cli-visuals; and two files with no extensions: balena and xdg-open.

Do I need to rename the balena file with an “.exe” extension?

Thanks,
pete


#7

Hey there @pdsavas,

Could you confirm that you downloaded the version for windows,
https://github.com/balena-io/balena-cli/releases/download/v9.6.0/balena-cli-v9.6.0-win32-x64.zip

It should contain the balena.exe inside.

Let me know how it goes,
Cheers


#8

@dansku,

I may have downloaded the wrong file; I grabbed: balena-cli-v9.5.0-darwin-x64.zip

Now I feel dumb. :slight_smile:

I’ll download the file you linked and try again.

pete


#9

@dansku,

I’ve hit another snag, this time when trying to push the code:


E:\Software Installation\Raspberry Pi\balenaDash>balena push balenaDash
[Info] Starting build for balenaDash, user psavas
[Info] Dashboard link: https://dashboard.balena-cloud.com/apps/1320466/devices
[Info] Building on arm02
[Info] Pulling previous images for caching purposes…
[Success] Successfully pulled cache images
[Error] Some services failed to build:
[Error] Service: main
[Error] Error: Cannot locate specified Dockerfile: Dockerfile
[Error] Not deploying release.
Remote build failed

I don’t think I missed a step. I changed the environment variable as instructed, and then attempted pushing the code I downloaded from GitHUB, which downloaded as “balena-dash-master.zip.”

What now?

Sorry for all the trouble,
pete


#10

@dansku, I am resending this in case you had not seen it.

Thanks.


#11

Hey @pdsavas sorry for missing your previous message.

Just to confirm, you downloaded balena-dash-master.zip, unzipped the file into a folder,
then did balena push balenaDash from within that new folder?

The folder should contain the Dockerfile file.

Could you confirm that for me?

Thank you


#12

@dansku,

Wow; I feel like the dumbest person on the face of the Earth right now.

I had downloaded the balena-dash-master.zip file, but had not unzipped it into the previously-created balena-cli directory. I just did that, and tried the push again, and it worked!

C:\balena-cli>balena push balenaDash
[Info] Starting build for balenaDash, user psavas
[Info] Dashboard link: https://dashboard.balena-cloud.com/apps/1320466/devices
[Info] Building on arm01
[Info] Pulling previous images for caching purposes…
[Success] Successfully pulled cache images
[main] Step 1/5 : FROM petrosagg/resin-wpe:raspberrypi3-30c7465
[main] —> 4b90e1c6a06a
[main] Step 2/5 : COPY udev-rules/ /etc/udev/rules.d/
[main] —> a5bec4045580
[main] Removing intermediate container bd5482576bae
[main] Step 3/5 : COPY wpe-init /wpe-init
[main] —> 75eb4be1792a
[main] Removing intermediate container 66eaf9d89885
[main] Step 4/5 : RUN chmod +x wpe-init
[main] —> Running in 48e7a4f537ff
[main] —> 1c141c5f2963
[main] Removing intermediate container 48e7a4f537ff
[main] Step 5/5 : CMD /wpe-init
[main] —> Running in 8cab4481158b
[main] —> 53e732f43719
[main] Removing intermediate container 8cab4481158b
[main] Successfully built 53e732f43719
[Info] Uploading images
[Success] Successfully uploaded images
[Success] Release successfully created!
[Info] Release: 33a57b4cda4b3d6df1c40b1f96b581b7 (id: 739669)
[Info] ┌─────────┬────────────┬────────────┐
[Info] │ Service │ Image Size │ Build Time │
[Info] ├─────────┼────────────┼────────────┤
[Info] │ main │ 97.45 MB │ 41 seconds │
[Info] └─────────┴────────────┴────────────┘
[Info] Build finished in 51 seconds


\
\
>/7
.-(6’
(=
./\ ) \ | / / | / > / j < _\ _.-' : ``. \ r=._\.
<\\_ \ .-.
\ r-7 -. ._ ' .
`, -.7 7) )
/ | ’ / `-.

|| .’
\ (
>\ >
,.-’ >.’
<.’_.’’
<’

I am now looking at the YouTube sign-in screen, so I guess it’s on to the next part of the tutorial.

Thank you again for your help, and most of all, your patience with this dumb old man.

pete


#13

I am glad it worked out @pdsavas,

We all make these silly mistakes all the time.
Anything we are here to help!

Cheers


#14

@dansku,

I have one more question for you if you don’t mind: How can I enable WiFi on the Pi? I got it working with a Google Slideshow, but I’d rather not have it connected with an Ethernet cable.

Thanks again,
pete


#15

@pdsavas,

The easiest way to configure WiFi on the RPi is when you generate the device image.

Let me know if this works for you.

Cheers


#16

@dansku,

Since when have I ever done it the easiest way? :smile:

Is there a way to change this on an active device? I’d rather not have to go through the setup all over again.

Thanks,
pete


#21

Hey @pdsavas,

You can insert the SD Card in your computer and a resin-boot partition will open.
Inside the partition, you will find a folder called system-connections where there is a sample file with .ignore extension. Copy that, remove the .ignore from the filename, and edit to add your wifi credentials.

Alternatively, if you connect to the device over ethernet, log into the host OS, then change the file in /etc/NetworkManager/system-connections. Change the example file mentioned above with a text editor such as vim and then restart the device.

This should do it :wink:


#23

@dansku,

That took care of it.
Thank you again for your help and especially your patience!

pete


#24

@pdsavas I am glad it worked out!

Anything we are here to help!

Cheers :wink:


#26

@dansku Hi I’m trying to push the balenaDash and it is not working. Everything is written correctly. The appfolder is where I want it to be.
I am a newbie so this is pretty much the first project for me…
Everything is runnin’ to the point where I wanna push the code.

"XX-MBP:~ XX$ sudo balena push balenaDash

| Packaging the project source…No such file or directory: /Users/XX/Library/Containers/com.apple.AddressBook/Data/Documents/iChats"

What am I doing wrong? Thank you


#27

Hi ruerdo
It looks like you might be calling balena push from outside of the project folder.
Please cd into the project folder and try again.
Regards
Thomas


#28

I seem to be having the same issue that is described above, but when I place the SD card into my computer to look for the folder called system-connections, but I can’t seem to find it. Alternatively, I did try changing the file via logging into the host OS, but was unfortunately unsuccessful there too.

Any other suggestions as to how I might be able to get this resolved would be greatly appreciated.

P.s. Just so you know I am using a Raspberry Pi 3 B+, and a Macbook Pro.

Thanks