SPI on BeagleBone Green


Today I stupidly updated my perfectly running BeagleBone Green to the newest balenaOS and now there are no /dev/spidev* devices file around. During boot the there seems to be an attempt to load the requird overlay but no devices are available.
From dmesg output:

[   47.915222] bone_capemgr bone_capemgr: part_number 'BB-SPIDEV0', version 'N/A'
[   48.121994] bone_capemgr bone_capemgr: slot #5: override
[   48.254885] bone_capemgr bone_capemgr: Using override eeprom data at slot 5
[   48.450756] bone_capemgr bone_capemgr: slot #5: 'Override Board Name,00A0,Override Manuf,BB-SPIDEV0'

However ‘cat /sys/devices/platform/bone_capemgr/slots’ results in

 0: PF----  -1 
 1: PF----  -1 
 2: PF----  -1 
 3: PF----  -1 

Any pointers on how to get the SPI device files (and drivers) working again are very welcome.

Hello there,

This looks like it might be down to the overlay having a different name. I’ve found a similar post for the BBB here: How do you enable the SPI pins so it might be that the dev overlays are not present.

Would it be possible to try the suggestion in that post? If that doesn’t work, please get back to us and I’ll get in contact with a device engineer to discuss what the issue might be. To help us, could you let us know what the previous version of the OS you were running on the Green was (and just to confirm, the new version)?

Best regards,


Hi Heds,

I checked /boot/overlays for the overlay names and BB-SPIDEV0 seems to be correct. Tried several variations but none worked. All attempted echo statements to /sys/devices/platform/bone_capemgr/slots fail with a write error.

The current version is 2.29.2+rev3, previous version was 2.12.7+rev1.

Best regards,


Hi Jac,

Thanks for checking this for us. Unfortunately I’m not familiar with the hardware setup on the BBG, so I’m going to get in touch with our device engineers and ask them for advice. However, they’re based here in Europe, so it’s unlikely we’ll be able to get some feedback to you until tomorrow.

We’ll let you know as soon as they’ve commented on the issue.

Best regards,


Hi. Can you please add the following to /mnt/boot/uEnv.txt:


and let us know if this fixes your issue.

1 Like

Thank you very much, that solved the issue.