Setting the Time on a Raspberry Pi

Hello All,

I am running into an issue with Time Synchronization on my raspberry pi, running balenaOS.

I followed these instructions ( to setup my pi to display a webpage in full screen without a nav bar, but when I point it to the website that I wish to display, the time is the only thing that seems to not be working.

I looked at this topic (, but so far everything I have tried has not worked. Any help, thoughts, or suggestions would be greatly appreciated.

Thank you in advance!


@rjoel98, just to clarify, is it a timezone configuration issue, or is it a case where the RPi cannot contact the NTP servers? Perhaps the easiest way to tell is to check whether the time is wrong by an exact number of hours, versus a seemingly random number of minutes. Or if the output of the 'date' command on a terminal shows a date incorrect by a number of days or even years!

It may also be relevant to check whether the network requirements are met. For the NTP servers to be reachable, the local network should allow UDP port 123 through:

@pdcastro, I do believe it is an issue with the timezone configuration, but I can’t figure out why. It seems to be stuck on UTC regardless of what I change, but the minutes are always on, it’s just the hour is exactly 6 hours ahead of where I would like it to be. Any suggestions on how to fix this, or a possible work around?

I’ve found a sample project that shows how to modify the timezone on a balena device with a Debian base image:

But looking at the balena-dash repo, it has 3 containers and only the wifi-connect container uses a base image that is compatible with the sample timezone project above. I suspect that the timezone needs to be set in the wpe container that controls what is displayed on the screen. I think this will require some investigation…

I had looked at that sample project before, and have attempted to set the WPE to the correct time zone, both fleet wide and on individual devices, but not luck. Is it true that there is no way to set the timezone manually on the device? Or is there another workaround that I might be able to try?

@rjoel98 take a look at this (closed) issue here: - let me know if it helps

@chrisys Thank you for that suggestion, I commented on the thread, and it appears that the person who created it actually made a pull request on the balena-wpe directory regarding updating it to WPE WebKit 2.22.5 and Poky Sumo, and it has just been accepted.

My next question would be is there any plan to update this directory to reflect the updates of the containers that it is composed of? The reason for me asking is because the features of this project are awesome, but I believe the benefits of updating are great. Thank you for your time on this matter.

@rjoel98 absolutely! Thanks for bringing it to my attention. I have just made a branch with the updates and a PR.

I’ve just been discussing with @petrosagg how we can make some improvements to the way tohora interacts and coexists with the use of the WPE_URL method of specifying the page so it’s likely we’ll hold off merging until then, but feel free to use the bump-wpe-version branch in the meantime.

1 Like