ScreenlyOSE not starting

I have installed Balena + Screenly OSE on a Raspberry Pi3 but Screenly is not starting. I get the Balena logo screen but then nothing. I am getting the following messages in the Balena Dashboard:

09.12.20 14:32:52 (+0000) screenly-viewer Still continue…
09.12.20 14:32:52 (+0000) screenly-celery [2020-12-09 14:32:52,868: ERROR/MainProcess] consumer: Cannot connect to redis://redis:6379/0: DENIED Redis is running in protected mode because protected mode is enabled, no bind address was specified, no authentication password is requested to clients. In this mode connections are only accepted from the loopback interface. If you want to connect from external computers to Redis you may adopt one of the following solutions: 1) Just disable protected mode sending the command ‘CONFIG SET protected-mode no’ from the loopback interface by connecting to Redis from the same host the server is running, however MAKE SURE Redis is not publicly accessible from internet if you do so. Use CONFIG REWRITE to make this change permanent. 2) Alternatively you can just disable the protected mode by editing the Redis configuration file, and setting the protected mode option to ‘no’, and then restarting the server. 3) If you started the server manually just for testing, restart it with the ‘–protected-mode no’ option. 4) Setup a bind address or an authentication password. NOTE: You only need to do one of the above things in order for the server to start accepting connections from the outside…

I have edited the redis.config file and set “protected mode no” and restarted redis and rebooted the device but this seems to make no difference.

The Pi has previously run ScreenlyOSE as a local install but i really need to be able to manage it remotely.

Any help gratefully received.

Hello there, are you using this guide?

Hi Anton,

Yes that is the one I am using. My first attempt to build the package failed. It’s all a bit strange because the device is visible in the Screenly dashboard and it seems to be working ok except no output on screen. I have tried 2 different HDMI screens.

I can send you screenshots from but can’t find how to attach them to this message.



Hi Nick, Screenly is currently under heavy development, as they are re-architecting the application.

In the meantime, can you try deploying from their experimental branch, and see if the results there are any better?


Bad News: I tried the experimental branch but it did not work and showed a different bunch of errors.
Good News: I reverted to the “master” version and it is now working fine.

I also discovered that the Raspberry Pi 3B+ I am using does not work with one of my HDMI-VGA convertors. I assume that this is because the convertor is unable to handle the resolution set by Screenly.

thanks for reading and helping


Thanks for your help

Hi Nick,

The Screenly folks released an updated version of their app on today. You may have better luck with that version. You can use the Deploy with balena button to replace the existing release on your device with that version. Please let us know how you make out.


I guess that’s why it’s now working. As you might have guessed I am a bit of a novice regarding Balena and gitHub how can I check if I’ve got the latest version? The capability to deploy and manage remotely is great I’ll be looking to learn more and use Balena for some other projects. I am using Screenly to build a system to show my housebound 89 year old mother-in-law family photos, videos, messages etc.

thanks for your reply


Hi Nick, glad its now working. Yes, they are continuing to fix bugs and are moving rapidly. The best way to update to the latest version is quite simply to click the blue “Deploy with Balena” button again, and just choose the same application that you already created in your balenaCloud Dashboard. It will then run a new build, and push it to the device.