Register device without BalenaOS

Hi,

I have a relatively unique where I need to deploy an app that we are developing on about 500 servers running intel i7 processors.

Obviously this isn’t an embedded system but the challenges of managing the running of the app across all these devices is pretty similar to the characteristic IoT challenge.

Ideally, I would run BalenaOS in a container on these servers and then manage my app in the standard way. However, when we tried following the instructions here: https://github.com/balena-os/balenaos-in-container on Ubuntu 19.10 (& 20.04) running on i7 when starting the container, the screen goes black (underscore flashing in the top-left), the user is dumped to the login screen and all the sound devices stopped working.

So basically, I’m wondering whether there is a client app (or potentially a standalone docker image) that I could run on a standard Linux distro (ubuntu) to register with balenaCloud and do things like join the VPN?

Otherwise, any advice for getting balenaCloud connection from a multi-tenant server would be very useful.

Cheers

Hey, thanks for the feedback. This seems like a really interesting use case, excited to see how this works out! Can you specify what version of BalenaOS you are trying to run with balenaos-in-container ? Could you also elaborate on what the sound devices are ? Thanks

Hey,

Yes, we are working with an essential retailer to deploy a machine vision app that will monitor the total number of individuals within the store and automatically regulate the flow of new customers to ensure safe social distancing.

Ordinarily we would deploy this sftware onto edge computing devices but our customer would like for us to deploy this onto their existing in-store infrastructure. Each store (of 500+ in total) is equipped with a linux machine with an intel i7 chip. These servers are conducting existing BAU workloads in addition to running our app.

It feels to me like this problem has a lot of similarity with the issue of IoT fleet management.

Anyway, we have been experimenting with trying to run balenaOS as a docker image so we can use balenaCloud to manage our software running on these servers. My colleagues and I have Ubuntu locally (also i7) and we downloaded the resin/resinos:2.50.1_rev1.dev-genericx86-64-ext image and used the scripts from the balenaos-in-container repo. On a Win10 pc this runs absolutely fine but on the Ubuntu machines (identicial hardware - DELL XPS 15 7590) we get the black screen and then dumped to login with all sound devices not recognised. We tried a couple of other images (2.48.0 I think) but with similar results.

Having dug around this a little more since my original post, we think that this might be related to the nvidia-docker plugin. The linux machines have this installed but it’s not available for windows. We only really started to think this because the black screen with flashing cursor but no prompt is something that we’ve only ever seen before when the graphics drivers crash.

Thanks for your help on this,

Linford

Hi, it’s not something I’ve personally come across. Could you collect some logs maybe we can dig further into it? For starters, can you share the dmesg when you get the issue?

Hi Linford, just catching up, did you get it working, or at least managed to get some logs out so we can look into this?