Raspbian and PCI cellular

Hi,
Is there any guide out there to help with connecting the PCI cellular modem on a Raspbian for FIN?

Thanks,

Hi @saoron

We do have a good blog post on how to use the modem with balenaOS

But the raspbian question is an interesting one. As the Pi doesn’t have a PCIe interface, there won’t be a blog out there. You might find more luck searching for how a normal linux laptop with pci-e modems configure the modem. I imagine you should see the modem using lspci and/or lsusb. And modem manager should pick it up…

Regards
ZubairLK

Just received a bit of info internally. The modem should show up as a regular usb cellular modem. So install NetworkManager and ModemManager and they should pick it up.

e.g. https://blog.soracom.io/beginners-guide-to-iot-cellular-connectivity-on-raspberry-pi-and-linux-devices-55d4f7489adf should be helpful

Thank you so much for the detailed answers, I’ll post back when I get this to work.

Hi, I was able to see the modem with mmcli, but it looks like it does not detect the Sim card, any advise here?

Here’s the log of >mmcli -m 0

/org/freedesktop/ModemManager1/Modem/0 (device id ‘6f28660af8c8de90ce20e13ef672ac94acbde1f2’)

Hardware | manufacturer: ‘QUALCOMM INCORPORATED’
| model: ‘QUECTEL Mobile Broadband Module’
| revision: ‘EC25EFAR06A03M4G’
| supported: ‘gsm-umts
| lte
| gsm-umts, lte’
| current: ‘gsm-umts, lte’
| equipment id: ‘866758044484067’

System | device: ‘/sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2’
| drivers: ‘option1, qmi_wwan’
| plugin: ‘Generic’
| primary port: ‘cdc-wdm0’
| ports: ‘ttyUSB0 (qcdm), ttyUSB2 (at), cdc-wdm0 (qmi), wwan0 (net), ttyUSB3 (at)’

Numbers | own : ‘unknown’

Status | lock: ‘unknown’
| unlock retries: ‘unknown’
| state: ‘failed’
| failed reason: ‘sim-missing’
| power state: ‘unknown’
| access tech: ‘unknown’
| signal quality: ‘0’ (cached)

Modes | supported: ‘allowed: 2g, 3g, 4g; preferred: none’
| current: ‘allowed: any; preferred: none’

Bands | supported: ‘unknown’
| current: ‘unknown’

IP | supported: ‘ipv4, ipv6, ipv4v6’

SIM | path: ‘none’


Bearers | paths: ‘none’

Hi @saoron , is sim card on the pcie modem on in the fin sim slot? Also which fin version do you have ?

Sim is on the Fin slot, Fin v1.1

Thanks for the info @saoron , I’m checking with the fin team if there is a good way to troubleshoot this. I know we have seen at least 1 or 2 instances where the sim slot was not soldered down perfectly and we had to ship out a replacement. Hopefully this is not the case on your board. Can you ensure the sim is firmly set in the slot. It also would be interesting to test a second sim if you have one on hand?

Actually when I use Balena OS the module connects and everything works as expected, Only on Raspbian I get the “no-sim” error.

hmm, @saoron when running with raspbian, what do you see on the i2c bus? from what i remember the sim card is on an i2c bus and i wonder if on raspbian it perhaps isn’t enabled by default.

@shaunmulligan thanks for the tip, I’ve enabled i2c but it still get error: “sim-missing”.

Any ideas?

Hey @saoron

The SIM card slot is electrically connected directly to the mini PCIe slot on the balenaFin (you can see this in the schematics here if you’re interested). This means there’s nothing with regard to the SIM connection that is software controlled and so nothing in that regard can change between balenaOS and Raspbian.

The only difference can be how the OS is handling the modem. I’ve just tested mine here with Raspbian lite and after installing ModemManager and rebooting I can see the device with the SIM card - but I don’t have the exact model of modem that you have to compare with. I would be interested to see the lsusb output from your balenaOS installation and then again from the Raspbian installation to check they are the same.