Raspberry Pi Zero and ttyAMA0 not working

I’ve been struggling a bit with trying to get an Adafruit Ultimate GPS running on a Raspberry Pi Zero. I’ve followed the steps here but haven’t had any luck. Specifically, when I do:
cat /dev/ttyAMA0
it just hangs, returning nothing. However, running the same command with Raspbian directly will return the expected GPS result (so I know the hardware is working).

I’ve tried RESIN_HOST_CONFIG_enable_uart = 1 and RESIN_HOST_CONFIG_dtoverlay = pi3-miniuart-bt (even though its a Pi Zero I tried this one anyway) on 2.0.6(dev) and 2.2.0(dev) and I still don’t have any result.

I really want to use resin to manage this, but I’m a bit stuck - any help that can be provided would be great.

Have you tried this with a production image? The dev images have a getty running on the serial port so possibly that could interfere with what you want to do.

Thanks so much willn, I just tried with the latest prod version and it works fine, so it must be the getty running. I tried to turn it off in the dev version but probably got a few things wrong - thanks again!