RabbitMQ "exec format error"

We try to use RabbitMQ for transmitting data between 2 parts of our application, both of which run on the device. When building and running the docker-compose file through local mode, everything goes fine. All 3 containers start properly and communicate with no issues.
Recently, we tried to build the application using the build servers. The build went fine, but the RabbitMQ container can’t start. It gives the following error: standard_init_linux.go:187: exec user process caused "exec format error".
Locally the application was uploaded with: DOCKER_API_VERSION=1.22 DOCKER_HOST=tcp://uid.local:2375 docker-compose up --build -d . It was deployed to raspberrypi 3 and on intel-nuc device type. Through the build servers, it was deployed to raspberrypi 3.
This is the content of docker-compose:

version: '2'


    image: "rabbitmq:management"
    restart: always
      RABBITMQ_DEFAULT_USER: "rabbitmq"
      RABBITMQ_DEFAULT_PASS: "rabbitmq"
      - "15672:15672"
      - "5672:5672"
      - 'rabbitmq_data:/var/lib/rabbitmq'

We also tried to pull the “rabbitmq” image, without the web interface. No changes.

Can you give me an insight on the error?

Hi @Krismix1, so that error means that you are running a container that is not of the correct architecture of the CPU. the default rabbitmq container is x86 and the raspberry pi3 only runs armv7 binaries.

To fix this you should change to useing arm32v7/rabbitmq:3.6-management or which ever tag is more appropriate version wise.

Thank you @shaunmulligan , I will have a look at that.

Hello there,
I am using a raspberrypi3.
I have the same issue. However, i noticed that with the arm32v7 architecture, the service just restarts continuously with no relevant message - this time without the “exec format error”.

Any ideas?


This was the issue!

@ask4ralph we are sorry for the inconvenience.
Thanks for posting back what was causing the issue for you.