Mounting external storage

I am trying to use mountto access the external storage with Balena Fin. I followed the steps of

And this is the output of listed USB ports:

If I want to use command:
image ,
what is the device-name and mount-point from the above pictures? I know the ID of the device is Bus001 Device006

Here I found the device name, but the mount command seems not works for my device


Hi, I think you are missing mount point in the command:

mount -t ntfs -o rw /dev/sda1

You can take a look at this repo which demonstrates how to automatically mount external drives when plugged.

@karaxuna Do I need to create a new mount point in filesystem? I am trying to store the audio signal detected by a microphone into an external storage. Do I need to create a WORKDIR /dev/sda1 in the current Dockerfile?

You should create a folder to mount to:

mkdir -p /mnt/sda1

Then mount:

mount -t ntfs -o rw /dev/sda1 /mnt/sda1

Then you can put audio data in /mnt/sda1.

@karaxuna It shows an error

@karaxuna Do I need to change the type of the device? I changed the type from ntfs to ext4 and it shows the error

Sorry for the above. In order to persist data, you have to store it in named volume. If your app has single container, default docker-compose.yml creates named volume for you that links to a /data folder (see Can you try /data/mnt/sda1 folder as a mount point instead?

@karaxuna It shows no such mount point

There is no such mount point in filesystem

Did you run mkdir -p /data/mnt/sda1 first?

@karaxuna. It shows the error with mkdir


Is your application multicontainer? If so, can I see it’s docker-compose.yml file?

@karaxuna I run with single container


Can you enable support access to take a look?

Yes, i enabled the grant support access

I need to know device id

I see that main container status is “Exited”. Were you running these commands in host OS?

I PM to you

The /data directory only exists in the container. In host os it’s /var/lib/docker/volumes/1622595_resin-data/_data. So here are the commands that I run to mount:

cd /var/lib/docker/volumes/1622595_resin-data/_data
mkdir -p ./mnt/sda1
mount -t ext4 -o rw /dev/sda1 ./mnt/sda1

container should write data to /data folder.