Local supervisor unreachable?

Having a little trouble with local dev mode on a Pi CM4. Worked fine in the past, but recently moved it to a fresh application, upgraded the supervisor (separate question, why does the default setup not include the latest supervisor?) and getting this error when trying to push locally:

balena push 325dcd8.local
Retrying "Supervisor API (GET" after 2.0s (1 of 5) due to: Error: connect ECONNREFUSED
Retrying "Supervisor API (GET" after 4.0s (2 of 5) due to: Error: connect ECONNREFUSED
Retrying "Supervisor API (GET" after 8.0s (3 of 5) due to: Error: connect ECONNREFUSED

Also, seems to be some funny business with the reporting of the CPU.

Any suggestions?

fwiw, I can get into the host no problem. Appears to be limited to supervisor 12.11.5 which shows a healthy state strangely.

balena ssh 325dcd8.local
Last login: Fri Nov 12 22:29:47 2021 from
root@325dcd8:~# balena ps
CONTAINER ID        IMAGE                                                                   COMMAND                  CREATED             STATUS                    PORTS               NAMES
fb421e0ae5e3        registry2.balena-cloud.com/v2/f5326125df6b1219ce06ff7be0edacaa:latest   "/usr/src/app/entry.…"   About an hour ago   Up 31 minutes (healthy)                       balena_supervisor

I tried to find a way to downgrade supervisor but it appears to not be an option?

Okay, I now I feel like a fool.
Forgot to enable local mode. :man_facepalming:

Hey @barryjump just wanted to check in whether enabling local mode solved your issue? :blush:

Sure did, thanks @Lizzieepton !