Jetson (Nano) Working CSI Capture Container

Hi,

I had a working container that allowed me to capture images from a Raspberry Pi CSI camera

nvargus-daemon &
gst-launch-1.0 nvarguscamerasrc sensor-id=0 num-buffers=1 ! 'video/x-raw(memory:NVMM), width=(int)1920,  height=(int)1080' ! nvvidconv ! nvjpegenc ! filesink location=test.jpeg

However, when I try it now, I’m getting strange errors.

nvbuf_utils: Could not get EGL display connection
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:557 No cameras available
Got EOS from element "pipeline0".
Execution ended after 0:00:00.127232917
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
(Argus) Error EndOfFile: Unexpected error in reading socket (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 266)
(Argus) Error EndOfFile: Receive worker failure, notifying 1 waiting threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 340)
(Argus) Error InvalidState: Argus client is exiting with 1 outstanding client threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 357)
(Argus) Error EndOfFile: Receiving thread terminated with error (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadWrapper(), line 368)
(Argus) Error EndOfFile: Client thread received an error from socket (in src/rpc/socket/client/ClientSocketManager.cpp, function send(), line 145)
(Argus) Error EndOfFile:  (propagating from src/rpc/socket/client/SocketClientDispatch.cpp, function dispatch(), line 87)

I’ve also tried with nvgstcapture-1.0 --automate --capture-auto --sensor-id=0 and get similar results.

I’ve tried the example image https://github.com/balena-io-playground/jetson-nano-sample-new but that doesn’t help.

I have confirmed by device-tree is setup properly, when used with Jetpack 4.6.1, the same command works as expected. I’m running a recently compiled BalenaOS image (balenaOS 2.88.4+rev17 with 4.9.253-l4t-r32.6).

Does anyone have a confirmed working setup that allows them to capture images from a CSI camera?

Thanks,

Andrew