Failed to download image ... due to '(HTTP code 404) no such image

I’m having difficulty updating my devices after using git to push and update. The logs indicate successful build and it shows on dashboard.

30.01.20 10:32:20 (-0700) Downloading delta for image ‘registry2.balena-cloud.com/v2/c017620d7c60f306893defdd7c717688@sha256:debd28ba3e1b3064848a8bd083ef30194e609489013ac6efeafc84d8a99af471
30.01.20 10:32:23 (-0700) Failed to download image ‘registry2.balena-cloud.com/v2/c017620d7c60f306893defdd7c717688@sha256:debd28ba3e1b3064848a8bd083ef30194e609489013ac6efeafc84d8a99af471’ due to '(HTTP code 404) no such image - no such image: registry2.balena-cloud.com/v2/c017620d7c60f306893defdd7c717688:delta-7171996827ff5648: No such image: registry2.balena-cloud.com/v2/c017620d7c60f306893defdd7c717688:delta-7171996827ff5648

At first I thought just patience was in order, but after several hours, the devices still get the same error when trying to update. Any thoughts on how to resolve?

Thanks!

Hi. Could you enable support access and send us the device UUID?

Sure thing. Support access enabled on device: c43fa96533ef2bc4b9a4579154924986

Hi Brant, sorry for the delay.
I have just looked at your device. Looking through our knowledge base there seem to be cases when this is caused by the software deployment process rather than by the device. In this case pushing a new release often solves the problem. Have you tried pushing a new - basically unchanged - release of your application ?
Cheers Thomas

Yes, when I first had the issue, I waited 1/2 hr then pushed another update. So that we are currently 2 updates behind. Should I simply push a 3rd to see what happens?

You could try that but I think I will have to take another look at the device what else I can see from logs. Would you please re-enable support access for me?

I most certainly can, enabled for 6hrs this time. I am testing 2 devices with this app and they are experiencing the same issue. So I suspect that build image might not be getting published. The other device is 65d055319cfd7b0d2b067f578a52996c, also with support access enabled. Thanks again.

I have just learnt that this might be connected to a known but yet unresolved issue.
As a fix you could try disabling delta updates on the affected devices. You will possibly have to reboot them after doing so.

Understood, disabled and rebooting both devices!

That was it. Disabling deltas fixed the update problem.

It did transition into a surprising permission error on my entrypoint.sh script through that’s preventing the container from starting. But I should be able to make progress again!

Sorry for the inconvenience. This issue is currently being investigated, we will keep you informed about any progress.

@samothx
We are having the same problem on my Balena application.
We tried to deploy a new image, but we can’t solve.

Is this a specific application problem? or our image problem?
We have another application which the same image is deployed, but we didn’t have problem on that application.
So, I think this caused by Balena application.

Please give me a help.

Did you try disabling deltas as mentioned above? What balenaOS version and for what device is this?

@dfunckt
Thank you for answer.
Our host OS version is balenaOS 2.38.0+rev1.
I’ll try to make delta updates disabled.