ERR_MULTIPLE_CALLBACK writing a .dmg file

Hi all, I’m trying to write a .dmg file from Windows with balenaEtcher portable 1.5.100.
After start the write process, balenaEtcher stop and return this error:

gui.js:126777 {"stack":"Error [ERR_MULTIPLE_CALLBACK]: Callback called multiple times\n    at Object.afterTransform (_stream_transform.js:87:31)\n    at Object.asCallback (C:\\Users\\User\\AppData\\Local\\Temp\\1dgGE37HBe821nsVru5iqACH638\\resources\\app\\generated\\etcher.js:8778:13)","message":"Callback called multiple times","name":"Error","code":"ERR_MULTIPLE_CALLBACK","image":"image_file.dmg"}
console.<computed> @ gui.js:126777
logException @ gui.js:134145
flashImageToDrive @ gui.js:155658
async function (async)
flashImageToDrive @ gui.js:155647
handleWarningResponse @ gui.js:155696
done @ gui.js:155773
ba @ gui.js:103360
ja @ gui.js:103374
ka @ gui.js:103377
oa @ gui.js:103391
lc @ gui.js:104062
jc @ gui.js:104056
mc @ gui.js:104073
sc @ gui.js:104142
Ia @ gui.js:109372
Ma @ gui.js:103470
Rc @ gui.js:104408
id @ gui.js:104377
exports.unstable_runWithPriority @ gui.js:109701
cg @ gui.js:105569
Ga @ gui.js:109360
gd @ gui.js:104367

I have no problems writing the same .dmg file from macOS with the same balenaEtcher release.

Any suggestion?


Thanks for creating this issue - looks like a bug.
Can you please share the OS and Etcher versions for both the setups? This will help us debug this

Also, can you share details about the .dmg file in question? Is it something that’s publicly available? If so can you link us to it

These are the platforms:

Windows 10 2004



macOS Catalina 15.15.5



Sorry I can’t share the .dmg file, it’s a company internal software.
I can say that it is a USB Device image created on macOS Catalina 10.15.5 from Disk Utility.
I clicked on the USB Device and select “Image from…”

Just to confirm, it’s not working on either versions on Windows? 1.5.100 and 1.5.101

Both balenaEtcher 1.5.100 and 1.5.101 does not work, same error.
I have not tried other balenaEtcher versions

Hello, what is the size of the image file ?
When creating the image file in Disk Utility, which format did you choose ?
For now Etcher will only work with “compressed” dmg files.


sorry for the late answer but I have tried again.
You are right, using a compressed .dmg file all work correctly.

Exist a list of the supported files?


1.5.102 dmg support has been improved, it may work with the dmg file that was failing before.

Hi there,
this is a list of what is supported by Etcher:

  • raw disk images;
  • raw disk images compressed with bzip2, gzip or xz;
  • zips containing a raw disk image;
  • dmg files (improved from v1.5.102 as mentioned above)