Eduroam campus wifi network

wifi

#1

I am looking for advice on how best to connect to eduroam. I have a research project I want to connect through resin and will be trying some things related to getting linux devices on eduroam.

In the larger picture however, a lot of universities use eduroam and if adding support or documentation for eduroam with Resin-wifi-connect is low hanging fruit then I would love to make this happen. It would be useful to connect devices to campus wifi networks using the captive portal.

I look forward to any thoughts or suggestions on this idea.

Thank you


#3

Hi @kanr, I am one of the maintainers of resin-wifi-connect and I will look into your idea later today and will get back to you :slight_smile:
Thanks a lot for the interest,
Zahari


#9

i’ve just set this up, and had exacly the same conversation with a resin dev in the UK. Take a look at https://docs.resin.io/deployment/network/2.0.0/

specifically the section on WPA2-enterprise wifi connection

basically, you mount your download OS image and inspect the boot partition and look for the system-connections directory

you should be able to edit the file /system-connections/resin-wifi to add the correct network config

the wpa2-enterprise example worked for a me on eduroam here;


#11

Thanks for trying it out, and giving feedback here. :slight_smile: We had some workshops and events at UK universities, and the network was almost always a tough part, good to know that we might have something to recommend the students (instead of 4G hotspots and similar “workarounds”). :wifi:


#12

Currently resin-wifi-connect does not support connecting to WPA2 Enterprise authenticated networks. We had a couple of questions about it in the last year and most probably we will add that in a 3.X release in the near future. So for now only the method @danb describes will work for using a eduroam with resin.


#14

I opened an issue in the resin-wifi-connect repo about adding WPA2 Enterprise in a future release: https://github.com/resin-io/resin-wifi-connect/issues/123


#16

All, Thanks so much for the replies I am very optimistic about my chances for success. I will keep this thread updated as I make progress.


#17

I am using resin in teaching and research scenarios and a WPA2 enterprise would be a great help. very happy to beta test anything you get working…


#18

Did/does your campus us certs with their eduroam logins? I tried this example just as you described and was not successful and my feeling is because when I connect with my phone or computer I have to accept a signed certificate. I can access the certificate in my macbook keychain so if its a matter of manually putting it on my device I can do that.

Thanks for the tips.


UPDATE: I made a goof in my edits. Your original suggestion worked. Thanks!


#19

:smiley: v cool, I was talking with a resin dev at an industry thing last night and he said that this is apparently being worked on internally to make config and access simpler…


#20

can i ask you where you screwed up? My file looks like this now.

[connection]
id=resin-wifi
type=wifi

[wifi]
ssid=eduroam
mode=infrastructure
security=802-11-wireless-security

[wifi-security]
key-mgmt=wpa-eap

[802-1x]
eap=peap
identity=my_university_id
phase2-auth=mschapv2
password=my_password

[ipv4]
method=auto

[ipv6]
method=auto

#21

Hi there! wifi-connect 4.2.0 was just released, and it adds WPA2 Enterprise support: https://github.com/resin-io/resin-wifi-connect/pull/226


#22

I’ve put together a short tutorial on what you need to do to connect a balenaOS device onto Eduroam - https://medium.com/@bucknall/balenaos-connecting-to-eduroam-26312e7859b5. Your milage will vary depending on what your university has in place for certificates, etc. but you should make some progress with the example config file! If that’s not working for you, speak to your IT services team for instructions on connecting to the network via linux. Typically the instructions are for Ubuntu (which is likely also for NetworkManager).


#23

Wow that was a great read; and perfect timing to I had just been poking around the performance monitoring and management tools available in BalenaOS.

@bucknall Thank you for sharing that write up on nm and thank you everyone for following up!