Disabling HTTPS Time Synchronization

Hello folks.

Main objective
Get device to synchronize time on a restrictive network with only NTP access.

I’m attempting to disable the HTTPS time synchronization (timesync-https.service) on my Balena device to prevent it from performing time sync over HTTPS, as my network environment causes this process to fail.
I only have access to NTP server and timesync-https is blocking chrony from running.
I’m performing test on latest build 5.1.20

Problem Description:
Despite following the Balena documentation and modifying my config.json to set the connectivity check URI to null and the interval to "0", my device still attempts to synchronize time using the timesync-https.service.
As indicated by systemctl status timesync-https showing the service in an activating state.

Configuration Attempted:
Here is the relevant section of my config.json:

"os": {
  "network": {
    "connectivity": {
      "uri": null,
      "interval": "0"
  • Updated config.json as described above and rebooted the device.
  • Checked the service status with systemctl status timesync-https, which showed that the service is still attempting to start.
  • Performed nmcli networking connectivity check and nmcli general status, both indicating that the network connectivity is full.

Have I misunderstood something? This should be possible since version v3.2.12.

Any advice or insights would be greatly appreciated.

Related topic with excellent information from nebbles.

It should be a string “null” and not a json null…

Now it works.

The github readme states interval = “0” should also disable connectivity, which did not work for me.