Disable console over Serial in Dev on RPi3?

local-mode
serial
raspberrypi3

#26

Ok, thanks for the details.

“Do you have any overlay” was a bit short for me to recreate the good context around :wink:


#27

Yeah, sorry about that. :slight_smile: Working with devices all day it takes a bit of context switching sometimes to make sure everyone’s talking about the same thing.


#29

Just for confirmation and others with the same problem. When using a production image, it was enough to change the host config as mentioned:

so no need to change cmdline.txt or mask serial-getty or lowering the baudrate!


#30

I folllowed the details above on my Dev OS to enable the serial port.

I use Bluetooth on the RPi to do BLE communications - after I open the serial port now, my bluetooth no longer works.

If I try Bluetooth before opening the serial port, it communicates fine, then as soon as I open the Serial Port, the Bluetooth fails.

I am on v2.29.2 of Device OS, I am testing on Prod now.


#31

@mhazley, How are you connecting your bluetooth device, and which commands did you run in dev?


#32

Hi, apologies all, this was a red-herring.

Stripped my pyserial code back to basics, removing some additional libs and it all seems to work now. Not 100% what was causing the issue at this point.