Device gets blocked when restarting the app through supervisor API




I think I reproduced the error (it happened to me twice). I am using a raspberrypi3 and a microservices application. Confirmed, I reproduced the error (a third time).

First, a container sends a message to the supervisor API to restart the application. After that (before restarting the application) I powered off the device. Finally, I powered on the device, and it gets blocked!:

  • All the services seems to be in status “Downloaded” or “Stopping”
  • If I connect to the host and type balena ps I can see that only the supervisor and a few services are running. I tried to restart all the services, even the supervisor, but nothing solved the problem.
  • I cannot shutdown the device nor restart the application. The error is: Device not found: DEVICE_ID (where DEVICE_ID is a sequence of numbers).
  • I tried to move the device to other application, but the problem is the same. The only thing I can do is re-flash the SD.

Do you know what can be happening?

PS: I am using and old docker base image (resin/raspberrypi3-python:3.6-slim). I’m gonna update it now, just in case this problem is related to the outdated docker base image.


Hi. Thank you for the report
Can you tell us please what OS version is this on?


It is Resin OS 2.12.3+rev1 (prod)


@jcozar is it possible for you to provide us an access to the device, so that we can troubleshoot it? If you can, please send me a dashboard link in a private message and enable support access from the dashboard (using Grant Support Access from the drop-down menu next to the light bulb icon). Thanks a lot!


Yes, of course @majorz


Facing the same problem since a week , any help would be appericiated !

9Apps | VidMate


Thanks for letting this know

VidMate | 9Apps


hi! could you confirm the OS version you’re seeing this on? and share the device uuid via private message, granting support access first?