CM4 PCIe issues

I tried installing Raspberry Pi OS (Linux raspberrypi 5.10.17-v8+ #1403 SMP PREEMPT Mon Feb 22 11:37:54 GMT 2021 aarch64 GNU/Linux) and it boots successfully, and finds the card (though drivers don’t load)

lshw output:

*-pci
          description: PCI bridge
          product: Broadcom Limited
          vendor: Broadcom Limited
          physical id: 0
          bus info: pci@0000:00:00.0
          version: 20
          width: 32 bits
          clock: 33MHz
          capabilities: pci normal_decode bus_master cap_list
          resources: memory:600000000-6000fffff
        *-network UNCLAIMED
             description: Network controller
             product: AR93xx Wireless Network Adapter
             vendor: Qualcomm Atheros
             physical id: 0
             bus info: pci@0000:01:00.0
             version: 01
             width: 64 bits
             clock: 33MHz
             capabilities: cap_list
             configuration: latency=0
             resources: memory:600000000-60001ffff memory:600020000-60002ffff

Update:
I tried installing the Arm64 RaspiOS buster build from 2020-05-27 and it works great. Still no luck with any Balena images, though. Installed 2.75.0+rev1 this morning and it still hangs on boot.

Hi, you get the problem with just this adapter card plugged in? https://www.amazon.com/gp/product/B07JBCL1CJ/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
Or does it need to have the Atheros WPEA-121N/W card plugged in to?

I was mistaken about the image version in my last message on this thread. I accidentally pulled down the Pi4, not CM4. The CM4 only has one release, and it’s not 2.75.0 :slight_smile:

I tested again just now using the CM4 image. The board boots up fine with only the adapter in place, and hangs when the adapter has the WiFi card installed.

Ok, we’ll order the adapter and see if we can reproduce it with any wifi card first.

Just a heads-up up, we ordered the adapter but they have pretty long shipping times to our location: 20May-15June. So keep you in the loop once we have it

Thanks a bunch @floion! I really appreciate you chasing this problem down.

Hey @floion I’m chasing down an issue with Ubuntu which might provide some context for your efforts: