Can't get omxplayer to output video over HDMI, only audio is working

Hi, balena OS 2.43.0+rev1 for the Raspberry Pi 3 has been released, could you give it a try, whether omxplayer work for that version now, as you’d expect? Thanks!

Hi there. I thought I join, since I try to get Audio running on a raspberry pi 3. (I have a working solution with mpg123, however I would like to pause and have more advanced features).

With x.38.x I had the same issue, that no output was given by omxplayer whatsoever.

I am using balena OS 2.43.0+rev1 as suggested. In order for omxplayer to work, I first had to increase [RESIN_HOST_CONFIG_gpu_mem] to at least 64mb . Now some sound is playing, but is incomprehensible. It is completely distorted. I tried to increase to 128mb but it is still not working.

Since I was playing an MP3, I thought this might be the issue. But mp4 does not work either (

FYI: I am using the 3.5mm jack, local sound, no video output.

PPS: mpg123 still works with the mp3 file on local jack. it is not played simultaoneously.

PPPS: I am still trying to get the hang of balena. This is my first application / device.

EDIT: mpg123 does not still work. see below

Hey @thfrei15 are you using the onboard 3.5mm jack? I remember I was doing a project with an rpi3 and spotify, and running any audio off the onboard jack was really distorted. As far as I could tell this seemed to be noise from the power source (but I can’t be sure).

I solved it with the pHAT DAC ( which output the sound super clearly from the start.

@CameronDiver Thanks. As of now, 3.5mm jack is working fine for me (using mpg123). So the rpi does not seem to have hardware problems.

However I made a mistake in assuming the mpg123 still worked with my omxplayer setup. I just retested it by invoking it in the docker container with mpg123 sample.mp3 and it was distorted as well.

Once I changed the memory back to 16, at least mpg123 works.

So I was thinking, maybe it is the core frequency. According to the raspberry pi docs, UART has influence frequency. The distortion might come frome a wrongly assumed base frequency?

However, in my belana device setup, UART is deactivated:

@thfrei15 could you share your application along with some instructions so we can try to reproduce this?

@thfrei15 thanks for sharing the repo, I can reproduce the issue. I then tried disabling the UART as you suggested (you need to click activate to turn on the configuration setting, and then change it to disabled), and then both mpg123 and omxplayer play the sample correctly, so it looks like you were correct in your thinking in the post above.

Responding to myself… I think the UART setting was a red herring. @thfrei15 if I take your code out of the equation, by using something like CMD while : ; do echo "${MESSAGE=Idling...}"; sleep ${INTERVAL=600}; done in the Dockerfile, both mpg123 and omxplayer perform as you would expect. I would check to make sure you’re not playing a few things simultaneously, this would explain why it works OK before you allocate the GPU memory as because without that omxplayer doesn’t run.