Can i use nmcli (network manager) of hostOS in any other container app

i need to use nmcli (network manager) which is available in hostOS but when i install it in any other container app , not getting installed and throwing below error

Hi, what is the Ubuntu image version that you specify in the FROM section in your Dockerfile?

FROM balenalib/%%BALENA_MACHINE_NAME%%-ubuntu:bionic-run

I forgot to ask about the device type as well. Is it a Raspberry Pi 3 or some other device?

Please note that you need to mask the NetworkManager service that you are installing in your application, since it will interfere with the one running on the host OS. More information at the bottom of this section:

I tried a very similar Dockerfile to yours and everything worked correctly (on a RPi 3 device type):

FROM balenalib/%%BALENA_MACHINE_NAME%%-ubuntu:bionic-run

RUN install_packages dnsmasq wget wireless-tools

RUN apt-get update
RUN apt-get install -y -d network-manager git

CMD ["sleep", "infinity"]

Please note that you may move installing network-manager and git to the install_packages command above.

actually i am using it on nvidia jetson tx2

I retied it with Jetson TX2 and got the same result. Possibly it was a temporary failure of the Ubuntu package repositories.
Can you please try my short Dockerfile above to confirm whether it is working for you.

if possible for you , can you try running wifi-connect on jetson tx2 , because for me its not working ,

i am getting the hotspot & able to enter wifi credentials but after that its not getting connected.

i used below reference to bring tx2 in hotspot mode -
Jetson TX2 Wifi Hotspot

got it working

its also working using -✓&q=

Great, glad that you solved it.