BalenaSense not recording measurements after reboot


I have gotten a Raspberry Pi Zero W with BME680 sensor up and running with balenaSense thanks to the brilliant guide from @chrisys.

However, I am having some trouble when I try to reboot device. After rebooting it stops recording measurements to influxDB. All services get up and running after the reboot, but it does noe record any new measurements to influxDB from the sensor. Anyone else with the same problem?

Is there a proper way of rebooting it other than using the «reboot»-function on balena dashboard? The only way I can get it working after a reboot now, is to do a balena push and that is quite time consuming to do everytime I reboot.

Steps to reproduce: reboot/restart device from balena cloud dashboard, or if I unplug my Raspberry Pi and then plug it in to the power outlet again.

I am running v. 1.4.0 of balenaSense.

Hey @danielgr welcome to the forums and thanks for posting your question here!

I have been able to reproduce this on my Pi Zero device (although interestingly it doesn’t seem to be a problem on Pi 3), so I will investigate further and report back.

@danielgr we’ve just bumped the version to v1.5.1 which changes how things are done quite considerably - can you give this a try and let me know if it works any better? It turns off the service dependencies which I think may have been causing your issue; at least I could reproduce it before and cannot anymore. It also changes to the use of telegraf which polls the sensor container and also has the capability to feed to InfluxDB cloud which I’ll do a blog post about shortly.

v1.5.1 seems to have solved the problems, thank you!

Hmm, seems like v1.5.1 has stopped recording iaq accuracy score for me. Did a clean install on my RPi, but didn’t seem to solve the problem. Is this a known issue @chrisys?

Hey @danielgr I changed everything to Telegraf in v1.5 which for some reason meant the IAQ accuracy score was being stored as a float even though it’s an integer. This meant if you upgraded from an older version the reading would fail to store due to differing column types. In v1.5.1 I tried to address this by converting the value on the fly back to an integer which seemed to be working but apparently not as you found.

I’ve addressed this in v1.5.2 by using Telegraf to make the conversion back to an integer and now (at least from my end) it’s storing the reading again. I hope it works for you too, let me know!

Thanks, v1.5.2 fixed the issues with IAQ accuracy👍🏼