balenalib/%%BALENA_MACHINE_NAME%%-ubuntu:focal udevadm issues

When using the image: FROM balenalib/%%BALENA_MACHINE_NAME%%-ubuntu:focal
with ENV UDEV=on, and privileged: true set in my dockercompose file, udevadm does not seem to work.

If I run udevadm control --reload-rules inside of the contianer, then I get Failed to send reload request: No such file or directory

I do not run into the issue on the non-focal images (e.g. FROM balenalib/%%BALENA_MACHINE_NAME%%-ubuntu)

It seems that the udev daemon is not being turned on in this image for some reason. If i run /lib/systemd/systemd-udevd --daemon manually in my entrypoint, things seems to work

Hi @mm-e1 ,

One thing that might not be immediately apparent is a script that exists in all our balenalib images, which helps mount devices, and does basically the same thing you menioned running udevd manually. Here is a link to the source: base-images/ at master · balena-io-library/base-images · GitHub

The easy way is to run /usr/bin/ this inside your own entrypoint script. It should take care of everything! Let us know if that solved your issue as well, it will be helpful to other users on the forums.

  • Flynn

This worked well. Thanks!