balena sense project failure to read sensor

So ive flashed the image to the Pi SD card, no dramas, everything appear great, apart from theres no data! Ah ha! A bet youve hooked up the sensor wrong? Well I dont think so…

I get this error:
2023-07-05T16:42:42Z E! [inputs.http] Error in plugin: [url=http://sensor:7575]: Get “http://sensor:7575”: context deadline exceeded (Client.Timeout exceeded while awaiting headers)

Constantly and no data. Ive tried a pi4 and a Pi 3 and its the same. I have it hooked up to a BME280 sensor, i2c, which I know works as I can detect it on the bus, and if I run plain old raspian, I can get temperature and humidity reads as expected. Anyone have any ideas?

Many thanks, James

Hello James, thanks for bringing this to our attention. I tried the same setup and was able to reproduce the error, which is actually in the sensor block. I’ve created an issue there so we can track the progress: RuntimeError when transforming bme280 values · Issue #16 · balena-labs-projects/sensor · GitHub . We will post an update here once it is resolved.

Thanks for looking into this Alan. I did try everything I could think of to fix it…:slight_smile:

If you are using the CLI instead of the “Deploy with Balena” button, in the meantime you can substitute the sensor block with this: image: in your docker-compose. It should be fully compatible and a drop-in replacement.

1 Like

@howesabout the issue with the sensor block has been resolved. If you try building the balenaSense project again it should work. Let us know how it goes!

1 Like

Hmm - Im still seeing the same error after a redeploy:

connector 2024-01-12T15:49:52Z E! [inputs.http] Error in plugin: [url=http://sensor:7575]: Get “http://sensor:7575”: context deadline exceeded (Client.Timeout exceeded while awaiting headers)


Hello @Howesabout if you are using balena push with the CLI to redeploy, please try the --nocache option and let us know if that works.