balena push builds failing to pull previous images

We build for two different devices and the ARM device build is working fine. However our AMD device builds have been stuck on the downloading previous images step for hours (normally takes <5 minutes). We don’t expect anything on our image to have caused this issue.

Pulling previous images for caching purposes...
Still Working...

I have tried to cancel these builds which was acknowledged through Github Actions but the Balena build is continuing showing 4 concurrent builds running that will likely never finish. Is there any way to cancel these builds through the Balena CLI or API? We can not push new builds to our AMD devices as they all fall victim to this issue. Any suggestions?

Screenshot of releases on fleet for context:

@trey could you please confirm if this is working? i don’t see any errors on the AMD application builders, however i would like to explore if this issue persists for you.

@mpous The builds did seem to eventually fail and just tried a build and it finished in ~3 minutes. In case this happens in the future, is there a way to cancel/force stop balena builds? Or do you think it was a service issue and the builds running issue was an unrelated side effect?

1 Like

Hello @trey it looks we had an issue on the x86 builders! Read here Status - Elevated GIT/Application Builder Errors

Thanks for the update! I have subscribed our team to the incidents page, super useful!

1 Like