Balena-Home Assistant supervisor

Recently I installed Balena-Home Assistant on my raspi4 with balena so I was trying to find out how to do something but I needed supervisor so I was looking at my balena dashboard and it said something like update supervisor so I liked it and it said next time you raspi4 reboots supervisor will be installed. So I rebooted it and it didn’t work. Please help.

Hello Lucian, what version of balenaOS are you running, and what version of the Supervisor were you trying to upgrade to? I’m also just curious what feature/functionality you were trying to gain by upgrading the supervisor?

@alanb128 @LucianDeKing Team Balena-

I’m having a similar challenge. In my case, I was looking for the “Supervisor” panel based on some Home Assistant documentation regarding upgrades and user management.

I realize from another thread here that the right approach for upgrading is to just launch based on a new container image. Here’s where some of my BalenaHub ignorance shines through: I deployed HomeAssistant from BalenaHub - not by cloning a repo to my local machine and doing a ‘balena push’.

I’m thinking that’s what’s required - but not even quite sure how to confirm which repo it is I should clone (fork, actually) so that I can start managing my own versions / images / builds? Is it this one?

I’m certain there’s a way I can confirm, from the dashboard (or perhaps CLI?) what repo is behind a particular Balena Application – but somehow I’m not seeing it.

Logging into Home Assistant, I get multiple notifications about vulnerabilities and the ‘urgent’ need to update. Trying to figure that out…

Thanks in advance for any insight / #ProTips / RTFM links! :slight_smile: I know I would be well served by walking through the available ‘master class’ offerings…


Just bumping this thread as I git a bit deeper in the Yak fur…

I’ve spent a fair amount of time (#LearningCurve) working with the HomeAssistant as deployed from BalenaHub. New to the platform, there’s a lot of surface area – from high level architecture / functionality, setting up Zigbee and ZWave, and building UIs (Lovelace?).

One of the attention-getting items is all the alerts about the need to upgrade. The BalenaHub build seems to be running a late-2020 image, if I’m parsing this screen correctly:

So I’ve forked the repo above, and think I’m ready to start learning about how to create an push an updated version. First though, since I’ve invested several hours into setup and configuration – I’d like to take a Snapshot / backup of the config, so that if I push a new image, I’ve not lost all that work.

Snapshot seems to be yet another feature accessed from the “Supervisor” panel. If not via this mechanism - as described in the forum thread below – is there an alternative method I could/should use?

I know these are total #N00b questions - appreciate the patience and any insight!


@LucianDeKing @SnoWake Could you please confirm the HomeAssistant version that you installed? What device did you use?


@LucianDeKing, @SnoWake Just jumping in here with some clarifications. There are two different supervisors being mentioned in this thread: The balena Supervisor which is a container that runs on balena devices that ensures your apps are running and coordinates with balenaCloud to download app updates. This is the one that can be updated on the balenaCloud dashboard. There is also an unrelated Home Assistant supervisor which was released in 2020 and manages a Home Assistant installation and related applications.

Note that there are four different ways to install Home Assistant as detailed here: Installation - Home Assistant - the “Balena Home Assistant” repo (GitHub - balenalabs-incubator/balena-homeassistant: Raspberry Pi + Home Assistant + balenaSense) uses the “Home Assistant Container” method without the Home Assistant Supervisor. (Note that this version is not yet on balenaHub, although a forked version appears to be.) However, it should install the latest stable version of Home Assistant (as of today core-2021.6.6) not one from late 2020. To eventually update this version, you would need to download a copy of the repo, and re-push the application (with the --nocache option) using the balena CLI. Since this project stores user data on a persistent volume, updating should not result in the loss of any customizations or user data.

I hope this clears up a bit of the confusion, but do let us know if you have further questions. If you do, it would help as my colleague requested to provide the device type, Home Assistant version, and source of where/how you installed it.

Hey @alanb128 – thanks so much! Yes, sorry if my vocabulary was confusing the issue - in every mention above of Supervisor, I’m referring to the Home Assistant supervisor - not the Balena one (which is, of course, present, and doing it’s thing just as expected).

A quick update here: Yesterday I had done exactly as Alan mentions above. I forked the repo:

and then pushed directly to my application using the Balena CLI. After the rebuild and restart of the various containers… it looked, at first blush, like everything was working fine. I see the new version of Home Assistant (core-2021.6.6) running, and as described, all of my configuration still existed from the persistent volume.

One thing I did later realize is that something broke in my Air Quality dashboard (Answering @mpous questions: my Home Assistant deployment was originally provisioned, on a fin, following the blog post, here:

Somehow, it seems I’ve broken MQTT. I’ll have to take a look after work - but my sensor telemetry goes flatline (and MIA for the ‘dials’) right at the time of upgrade.

But at least the upgrade worked, and the UI isn’t nagging me about critical vulns.

@alanb128 I’m starting in on the tedious process of removing all my devices from my previous hub, and adding them to Home Assistant. Which ZWave Integration are you using, if any? I only had the legacy / deprecated one, prior to the HA upgrade - but now, I have the options of OpenZWave (with it’s warnings and ‘no further development’) and ZWave JS. Clearly the latter is the future – but any thoughts / guidance on what I should do, for an immediate cutover (9 days and counting until my SmartThings v1 hub goes EOL).

Thanks for the great support! SO much surface area here - just within Home Assistant. From understanding it’s deployment (Supervisor, Container, etc) to the Integration ecosystem, Automations, Dashboards…) there’s a LOT to learn that is entirely beyond the scope of Balena. And yet there’s an intersection, as well. #LearningFTW

You’re welcome @snowake! I’m glad your Home Assistant core part is a bit sorted out. Note that in balenaSense 2 (if you have upgraded) the MQTT part works differently than it did in earlier versions and the documentation for that part is a bit outdated in Monitor air quality around your home with Home Assistant and balena - we’re working on an updated post to be published shortly.

For Z-Wave, I’m using OZW from a few years ago; it still works fine - for now. I suppose if I were starting over today, I’d suggest using ZWave JS, as long as the current limitations (Z-Wave JS - Home Assistant) are not a show stopper for you. Hopefully you have enough time to test it out before your cutover!

Thanks again @alanb128 - as I think you’ve given me a clue to pursue. While I deployed a new build of the Home Assistant application (which includes the MQTT component) but have not updated the Balena Sense (2?) deployment — then perhaps I’ve got a mismatch of configs?

Currently on the Home Assistant application, I’m seeing this in the logs:

 2021-06-24 05:59:29 ERROR (MainThread) [engineio.client] packet queue is empty, aborting
 homeassistant  packet queue is empty, aborting
 homeassistant  2021-06-24 06:00:56 ERROR (MainThread) [engineio.client] packet queue is empty, aborting
 homeassistant  packet queue is empty, aborting
 homeassistant  2021-06-24 06:02:21 ERROR (MainThread) [engineio.client] packet queue is empty, aborting

And my dashboard looks like this:

(that screenshot would have been more representative of the change, taken on the day of the upgrade - where you could clearly see the moment where the telemetry stopped flowing. :D)

Off to see what I can find out about Sense 2, or anything else that might help me understand what’s going on, and how to fix it.


Just bumping this thread again, because I just learned of another compelling use case for having the Home Assistant Supervisor ‘panel’ (?) enabled - and that it for access to the AddOn library - in my specific current interest, Node Red, as described in this video:

So - whether it’s how / where to manage my YAML configuration file, to how to install AddOns – I’m trying to adapt the ‘general population’ documentation for the Home Assistant ecosystem to apply to my “running it as a container on Balena” deployment.

Thanks in advance for any insight or guidance. I’d love to get to the point where I could figure this out, and simply “add Code Red to my upstream config, and push a new build” :smiley:


@snowake you should still be able to use ad-ons such as Node Red without the HA Supervisor but as you suggested, it will be more work to get them configured! I’d search for “node red on home assistant core” for some options.
Also, in response to your previous post, please check out the latest feature additions and removals in balenaSense 2 before upgrading. (See the readme in the repository: GitHub - balenalabs/balena-sense: Take readings from a BME680 sensor or Sense-HAT on a Pi or Pi Zero, store with InfluxDB and view with Grafana) For the moment, air quality readings are no longer supported.

@alanb128 Thanks for the feedback, and confirming the art of the possible. Interestingly, just because I’ve got SO much learning curve before me – I stood up a ‘vanilla’ Home Assistant on a RPi4 and right out the gates, I’m noting some differences. In my Balena-deployed HA instance - many of the Integrations I’ve tried to add (SONOS, Harmony Hub, Apple TV, and many others) seem to be failing (“no SONOS devices found”, etc)… and yet, three clicks into the vanilla install – I’m presented with this screen. All of these integrations are relevant to specific devices present in my environment:

Of course, I’ve no clue if this is a byproduct of including HomeAssistantOS as opposed to just “Core”, or having the Supervisor module, or … ? I assume I’ll figure some of that out over the coming days – as well as start to get a handle on the more ‘mainstream’ approach to doing Dashboard development, managing integrations, etc.

I’m wondering, having now walked through configuring several of these integrations, which fail when attempted on the Balena-deployed HA instance – Is there some characteristic of the deployment, or the individual containers’ outbound access to other devices on the local LAN?

I wonder if it has anything to do with networking, and if using a docker-compose and setting networking to host would help? I’m not familiar with HA, but I wonder if the bridged networking is what’s preventing them from being discovered.

1 Like

@dtischler Great suggestion. I wasn’t familiar with this setting, nor had I given much thought to how the individual containers communicated “on the wire”. I’ll give that a shot, and see if it has an effect. Thanks again!