Why can't I connect to `github.com` when building an image?

I get this error when I run balena push:

[xserver]    Step 36/45 : RUN luarocks install pulseaudio
[xserver]     ---> Running in ea54ee047a3c
[xserver]    Installing https://luarocks.org/pulseaudio-0.3-1.rockspec
[xserver]    Cloning into 'lua-pulseaudio'...
[Info]       Still Working...
[Info]       Still Working...
[xserver]    fatal: unable to connect to github.com:
[xserver]    github.com[0:]: errno=Connection timed out
[xserver]    Error: Failed cloning git repository.
[xserver]    Removing intermediate container ea54ee047a3c
[xserver]    The command '/bin/sh -c luarocks install pulseaudio' returned a non-zero code: 1

I had a similar command connecting github.com working today, but this error comes back from time to time and it halts my progress… Would it be possible to debug this issue?


It might have been an intermittent issue. Perhaps github was down at the time you were creating the release?

Are you still seeing this?


@rahul-thakoor I settled upon using:

RUN luarocks install https://github.com/doronbehar/lua-pulseaudio/releases/download/v0.3/pulseaudio-0.3-1.src.rock

Which does work from some reason… Tried now the original luarocks install command and it failed the same way. I’m not sure it ever worked for me BTW.