Using Public URL to access webpages on local network

Hi Mark,

After our success with the port forwarding last week we decided to try it on the device on site. I have attached the warning message that I received.

The device we have been testing on is also a raspberry pi 4, although it is in our offices.

How can I verify that the host is secure, and add it to the known_hosts?

Hi @gregorr1

You can try ssh-keygen -R <IP> to resolve the above warning. A google search points me to some of the other methods tried by users to resolve this here: verification - ssh remote host identification has changed - Stack Overflow

Let us know if you are able to resolve the above warning or come across a different issue.


I managed to sort the above warning. I then set up the port forwarding and attempted to access the webUI of the router. However, I got an empty response error.

Could this be due to the fact that there is a container set to port 80 on this device? I tried stopping the container but this didn’t solve the issue.

Hello gregorr1

I have found some posts on the internet that suggest replacing localhost in the commands with on Windows to force IPv4 mode. Please give this a try and let us know what happens.

I would also suggest stopping the container so that you don’t have two processes trying to access port 80.

Hi @markcorbinuk

Thanks for the reply, I tried stopping the container and using for the commands but it still didn’t work.

I’ll keep searching - if I find a solution I will update this feed.


Thanks @gregorr1
Please let us know if you find a solution to this.