Serial port usage

@imrehg @diegosucaria I honestly don’t understand how that would affect the result, unless @diegosucaria was targeting the wrong serial port.

Switch Pi3 Bluetooth function to use the mini-UART (ttyS0) and restore
UART0/ttyAMA0 over GPIOs 14 & 15.

Hm, probably my bad then.

mmmm… in the serial-test I tried both, ttyS0 and ttyAMA0 since I wasn’t sure, none worked with 2.x

ttyAMA0 was working on my app with OS 1.x and is the one that is working now in 2.x after disabling bt

@diegosucaria by default on rpi3 BCM 14 and BCM 15 are mapped to /dev/ttyS0 since tty/AMA0 is used by Bluetooth. The param you set on the config.txt file restores tty/AMA0 to map BCM 14 and 15

so you should be able to work on ttyS0 or ttyAMA0 if you enable the pi3-disable-bt overlay

Sorry if this is bumping a post too old but this seems directly related to the top post. I inherited this project so I may be missing something that was customized, but I can’t seem to track it down.

My goal is to use the Raspberry Pi Zero W UART on GPIO14 and GPIO15 with nothing else sending data on those lines.

I can use the UART fine, however, when the Zero boots, I get texts coming over the UART. Once the pi boots, everything works great.

However, when the zero boots, I am getting the following text sent over /dev/ttyAMA0 :

441 bytes read in 2 ms (214.8 KiB/s)
## Executing script at 02400000     
Scannic ** U e 2s2Carltei gtc** Unt 9273328 bytes read in 407 ms (21.7 MiB/s)
Kernel image @ 0x080000 [ 0x000000 - 0x8d7ff0 ] 
## Flattened Device Tree blob at 1efe9d00
Booting using the fdt blob at 0x1efe9d00 
reserving fdt memory region: addr=0 size=1000
Using Device Tree in place at 1efe92

This seem to happen regardless if i use rpi3-miniuart-bt or rpi3-disable-bt

I want to stop this text being sent by the OS over this UART. Disabling bluetooth is also desired but not the intention of this question.

I’m not sure if this is correct but this is the example boot log from the device dashboard:

15.01.20 13:35:06 (-0800) Applying boot config: {"avoid_warnings":"1","disable_splash":"0","dtoverlay":["pi3-miniuart-bt"],"enable_uart":"1","dtparam":["i2c_arm=on","spi=on","audio=on"],"gpu_mem":"16"}
15.01.20 13:35:06 (-0800) Applied boot config: {"avoid_warnings":"1","disable_splash":"0","dtoverlay":["pi3-miniuart-bt"],"enable_uart":"1","dtparam":["i2c_arm=on","spi=on","audio=on"],"gpu_mem":"16"}

15.01.20 14:00:42 (-0800) Applying boot config: {"avoid_warnings":"1","disable_splash":"0","dtoverlay":["pi3-disable-bt"],"enable_uart":"1","dtparam":["i2c_arm=on","spi=on","audio=on"],"gpu_mem":"16"}
15.01.20 14:00:42 (-0800) Applied boot config: {"avoid_warnings":"1","disable_splash":"0","dtoverlay":["pi3-disable-bt"],"enable_uart":"1","dtparam":["i2c_arm=on","spi=on","audio=on"],"gpu_mem":"16"}

cmdline params:

root@a849bbb:/resin-boot# cat cmdline.txt 
dwc_otg.lpm_enable=0 console=null rootfstype=ext4 rootwait vt.global_cursor_default=0

How do I silence the output being sent to the UART on boot?

Hi @marcidy and welcome to the forums!

Have you tried using a production version of balenaOS? The development version has a serial console enabled, see this issue: https://github.com/balena-os/meta-balena/issues/1387

1 Like

I believe i’m using a production image:

image

right now this is the only image / device I’m using.

Hi, the logs you’re getting look like u-boot output. You can try to add the silent environment variable