Running ./configure inside container

This question isn’t specific, either to balenaOS or a package.
I ran into an into trying to install ser2net from apt into a container, with the build reporting “package not found”. So what I did was to pull the package down, and put the code into a container. But when I run ./configure in the source folder, I get “permission denied”.

What is the best approach, when a package is local, to installing it in a container?

Thanks for the advice.

OK, well it looks like I just needed to take one more step backwards…and run from a compose file instead :slight_smile:

So now, I can remove the serial server from my own code completely, and run it in its own container.

So just to add to this, when I was building locally, all my file permissions where are stated in an ‘ls’, but when deploying as I was deploying from Windows to a Linux host, permissions where being modified by Docker.

I was trying to call ‘./configure’ but the configure file was not executable.

Learning every day. :slight_smile: