Resin-WPE : GStreamer-CRITICAL Error with youtube live video


I test the resin-wpe with a live video from youtube :


But the video won’t start and I get this error :

(WPEWebProcess:39): GStreamer-CRITICAL **: _gst_util_uint64_scale: assertion 'denom != 0' failed

Any idea ?



can you check all the configuration variables that you have entered and make sure that they are entered as described in the resin-wpe repo?


I set these variables :

RESIN_HOST_CONFIG_gpu_mem_256 = 128
RESIN_HOST_CONFIG_gpu_mem_512 = 196
RESIN_HOST_CONFIG_gpu_mem_1024 = 396


Are there other conf variables to set ?

I guess you can set those if you need to:

If you try with a different youtube url (not live video), do you get the same error?

I didn’t get the error with a normal youtube video

Can you file an issue in the github repo describing exactly that behavior please in order for the maintainer to see it?


I get this response from WPEWebKit team :

You need a patched GStreamer to solve this issue. It’s solved in WebKit upstream here:
I’ve just backported the patch to gst1-plugins-good in buildroot here:

How to apply this to the resin-wpe project ?

Hey @samoud, if the patch has been applied in the meta-wpe layer upstream, then it might be as easy as updating the version of meta-wpe in and rebuilding the base image. I haven’t looked into the meta-wpe history to see if they have that patch included, so it would need a little research.

Thanks @shaunmulligan

I asked them and apparently it’s not applied yet.

By the way I updated the version of all submodules but I get some new errors (and added some new layers meta-openembedded/meta-networking and python) :

| checking for cairo's EGL functions feature...
| checking whether cairo's EGL functions feature could be enabled... no (not required by any backend)
| configure: error:  EGL functions feature could not be enabled
| NOTE: The following config.log files may provide further information.
| NOTE: /home/samoud/resin-wpe/base-image/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/cairo/1.14.10-r0/build/config.log
| ERROR: configure failed
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_configure (log file is located at /home/samoud/resin-wpe/base-image/build/tmp-glibc/work/cortexa7hf-neon-vfpv4-oe-linux-gnueabi/cairo/1.14.10-r0/temp/log.do_configure.31984)
ERROR: Task (/home/samoud/resin-wpe/base-image/build/../poky/meta/recipes-graphics/cairo/ failed with exit code '1'
NOTE: Tasks Summary: Attempted 1294 tasks of which 1253 didn't need to be rerun and 1 failed.

They just updated meta-wpe but I still get this EGL error.

I tried to add egl to /base-image/meta-resin-wpe/recipes-core/images/ :

DISTRO_FEATURES_append = " egl" but it ignore it.

Any Idea ?

You mean that you still get the initial error:

(WPEWebProcess:39): GStreamer-CRITICAL **: _gst_util_uint64_scale: assertion 'denom != 0' failed ?

Nope, this one when I try to build the yocto image :

I’ll ping the team for more ideas on this



Do you know how can I add DISTRO_FEATURES to meta-resin-wpe ?


please check this out:

The issue is closed now and it should be working.