Getting started with Bookstack

I am just getting started with balena, so I am not sure how to do anything. I want to be able to make changes from afar and see the results, so I set up a production machine with a public url. Balena tells me that I have bookstack running, but even though I set the APP_URL like it says here: GitHub - klutchell/balena-bookstack: bookstack stack for balenaCloud
the url for my machine still forwards now to a local, broken link. Do I need to change something within the program, and how do I do that?


Thanks for reaching out. The APP_URL should work without any code modifications.

Can we try vanilla service i.e. accessing the service via http://boostack.local (removing the APP_URL var)?

I started with that, but it did not work either.
Actually, I set the variable at the fleet level but somehow an exception for the main device got set up. After taking away the exception, things still do not work, though now I get something different:
tunneling socket could not be established: 500

One possible reason is because nothing is listening on port 80 on the device.’

Hello, after setting the APP_URL to your device’s URL (in the format and making sure you are overriding the default fleet setting) you may still see the tunneling socket error. Sometimes the browser will cache that message and be a bit persistent. Try CTRL + F5 (on Windows) in your browser or test on another browser you haven’t attempted to access the device with. (Simply refreshing may not be enough.)

1 Like

Updating my previous post because the URL format was cut off. It should be https://<UUID> where <UUID> is the device’s UUID.