BalenaSense Problem with Orange Pi Zero

Hello everyone, I’m having problems with BalenaSense project on my Orange Pi Zero. I’m reading the guide from here:
When I try to push the project code to the Orange Pi I have the errors on the pic below. By default the i2c is disabled in armbian but I don’t know how to enable it here in balenaOS ( I read here: but don’t know how to use modprobe command). Also in dashboard there are errors for sensor and telegraf. Please help me to get data from the BME680 sensor.

I had the same thing, if you do the push again and put the --convert-eol at the end it *should update and push just fine. The windows end of line messes up the build.

I tried with --convert-eol it completed the installation, the unicorn appeared but now I have errors in the dashboard for sensor and for telegraf.

Hi, from the logs it looks like we are not able to access the i2c(or the sensor ). we should first check if RESIN_HOST_CONFIG_dtparam="i2c_arm=on","spi=on","audio=on" is set properly, this is default we are making sure it wasn’t changed. second we should restart the sensor, telegraf.

Hey, few more details.

  • If you need to run the modprobe cmd. You’ll need to add the cmd in the dockerfile.
  • the env var can be set using the dashboard, please check this article on how to do it.

I have set the custom configuration variables but still not work