balenaEtcher-Portable versions > 1.5.73 NOT working on haiku image


I tried to use the current version (1.5.98) of Etcher for writing to a USB flashdrive with the haiku image but failed.

version 1.5.73 was successful.


Hi there, can you tell us what failed exactly? What OS are you running and what error message did you see?



balenaEtcher-Portable-1.5.86.exe - same error

balenaEtcher-Portable-1.5.73.exe - success

OS Windows 10 Pro x64


Hi, I was unable to reproduce the issue using haiku-r1beta2-hrev54154_111-x86_64-anyboot.iso and balenaEtcher portable v.15.99 or v1.5.98 on Windows 10 pro x64. Would you be able to share the exact version of the haiku image you are using? If its possible to upload and share the image itself that would be even better!



1.5.99 - same error

I have downloaded the image and I was not able to reproduce the issue. Could you please confirm that at this moment you are able to flash the same image to the same USB drive using the same USB port with Etcher v1.5.73 but both Etcher v1.5.98 and v1.5.99 fail? Could you also specify whether you are trying to flash from the zip archive or from the unpacked iso?


1.5.73 - confirmed successful
1.5.98 & .99 - confirmed failed.

from .iso, that is: haiku-r1beta2-hrev54154_111-x86_gcc2h-anyboot.iso

Hi there,
talking with the Etcher team we don’t think the problem is strictly connected to the image. Could you try if the same error occurs with another image?
In addition it would be very useful for us if you could give us the console tab output that you can bring up by pressing ctrl + shit + i


previously: 32bit

now 64bit - same error

thanks for your feedback. We have identified the issue and expect it to be fixed in Etcher 1.5.100. Feel free to let us know if the problem persists.


Tested 1.5.100, successful.