Balena Sound on on Pi Zero W

Hello dear Balena members,

I’ve have been able to setup a Raspberry Pi Zero W with Balena OS and Balena audio (bluetooth etc).

It was not easy! Anyway, I’ve noticed services were offline…like bluetooth…and sound was stuttering. Now it runs nice but I dont understand why this happens? I dont understand some things, does the device have to be online to function?

I opened my cloud/device for you to research. Here some images

username: g_bert_krus

The device need not be connected to balenaCloud to run the project you’ve pushed, but by letting it do so allows you to monitor and manage it. What exactly would you like help with? To better understand balena you may start from here:

The music by bluetooth is stuttering all the time. I dont know why? On my smarthphone it sounds perfect…

hey @Bert,
since you have only one device in our application. can you try to disable the multiroom feature as per this section in the readme and see if it improves performance?


Where do I need to configure multiroom? At device config, -variables or -service?

Ok I disabled multiroom somewhere. Right now I have no sound at all, it says: usr/bin/bluealsa: Unsupported RTP payload type: 1

Just to confirm, you disabled multiroom by adding the DISABLE_MULTI_ROOM variable (with any value, for example: 1) in the Device Variables section of the dashboard? Have you tried varying the distance between the Pi Zero and the bluetooth audio source?

Yes I did vary distances.

I changed hifiberry-dacplus in hifiberry-dac. That makes the dac work, even though its a plus.

It takes a huge time before bluetooth starts after startup, if it starts at all…

Im making a hifi adapter for somebody. Right now its too unstable to pleasy anybody. The music still stutters too.

How can I view CPU usage?

And yes I disables multiroom, it was confirmed.

Sound stutters all the time :confounded: the CPU however is not causing this, it is average below 10% usage

LG Nexus smartphone and Chromebook dont detect the device :roll_eyes: the Redmi does however

Hey, we’ve seen some issues with stuttering on certain rpi3 devices when using certain bluetooth baud rates. Could you SSH into the host OS and post the content of /usr/bin/btuart please?

Well, I just read that there is a lot of complaints about the Pi Zero W. The wifi supposedly interferes with the bluetooth, causing the stuttering audio. I need to think, maybe I will buy the Pi 4.

Thanks so much, it is really interesting to experiment with Balena.

Glad you like using balena! As you mentioned, we have seen some issues with wifi and bluetooth interfering, so if you can provide us with the result of the command Cameron posted above, it will help us in narrowing down when the stutter happens and to check if there is anything we can do about it. Thanks!

To be honest, I dont know how to use SSH? Do you have tutorial which is not too complicated? :upside_down_face:

Yeah no worries, here are the docs for it:, so you just choose “Host OS” as target, and you run the command from above.

I have the same error messages on my Pi Zero W running Balena Sound as the OP does in his 3rd and 4th images.
Two every second, one says “23.05.20 12:45:36 (+0100) snapcast-client 2020-05-23 11-45-36 [Error] (worker) Exception in Controller::worker(): connect: Connection refused” and the other “23.05.20 12:45:36 (+0100) snapcast-client 2020-05-23 11-45-36 [Error] (stop) Error in socket shutdown: Transport endpoint is not connected”.

However although this doesn’t seem to prevent me from playing over bluetooth, it won’t play as part of the multi room set-up with snapcast and it also seems to mess with the Spotify connection. Sometimes Spotify is listed as running on the device but it does not appear in my spotify devices list and sometimes it just quits.

It has worked sometimes and then it stops with no obvious change. It spends much more time not working than working though.

I have a justboom digi zero on the raspberry pi and have provided my spotify credentialsas fleet device variables.

Any ideas?

Hi there, it seems that as described in our blog if you’d like to add the multi-room audio feature you can use any device type except the Pi Zero as the master, and it’s recommended that you use a Pi 4.
This is what you are trying to do?

Well I tried the Pi Zero for a standalone blue tooth speaker, which did not work out as expected. The audio kept stuttering. From what I have researched it seems that the wifi interferes with bluetooth, which causes the trouble. I might try Balena later with a Pi 4.

Hi @Bert – thanks for the additional info. We have an issue tracking Raspberry Pi Zero performance for balena Sound here: Would you be able to add your experience, and details of the devices you’ve tried streaming from, to that issue?

All the best,

Hi. I have a Raspberry Pi 3 acting as the master and the Pi Zero is the client. When I want to play multiroom audio then I select the Pi 3 but sometimes I just want to play in one room and select the Pi Zero. However, when I am getting the error message in question, the Pi Zero does not play if I play anything to the Pi 3 and it also does not play if I try to select it as a spotify device, most of the time it does not even show as an option.

Hi there,

Sometimes the Pi Zero has difficulty keeping up with the other devices with multi-room. If you would like to play the Pi Zero on its own, we would recommend disabling multi-room (instructions here

With regards to the Pi Zero not showing up. This could be related to performance. Do we know what version of the zero you have?